LINUX.ORG.RU

Ubuntu 20.04: Почему Chrome не принимает ключи из desktop-файла?

 ,


0

1

Всем привет!

Ubuntu 20.04, Chrome 91

В процессе включения аппаратного ускорения в Chrome возникла проблема: браузер запускается с определенными ключами из терминала, но эти же ключи не срабатывают, если их прописать в desktop-файле.

Подробнее.

  1. Запускаю браузер из терминала:
google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder
  1. Перехожу на chrome://gpu. Все работает отлично:
<...>
Video Decode: Hardware accelerated
<...>
  1. Копирую desktop-файл из /usr/share/applications в ~/.local/share/applications, редактирую:
Exec=/usr/bin/google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder %U
  1. Перехожу на chrome://gpu. Ключи не подхватились:
<...>
Video Decode: Software only. Hardware acceleration disabled
<...>

Пробовал решить проблему разными способами: update-desktop-database, редактирование глобального файла, вставка ключей после каждого Exec, закрытие браузера. Ничего не помогло.

Как запустить Chrome с необходимыми мне аргументами без терминала?

Спасибо!

Exec=/usr/bin/google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder %U меня лично смущают символы «=» в этой команде. Если в кавычки заключить команду «становиться хуже»?

anonymous ()
Ответ на: комментарий от anonymous

Оказывается можно использовать «=». Тогда не знаю…

anonymous ()
Ответ на: комментарий от ZenitharChampion

С кавычками наигрался вдоволь:

Exec="/usr/bin/google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder %U"

Exec=/usr/bin/google-chrome-stable "--use-gl=desktop --enable-features=VaapiVideoDecoder %U"

Exec=sh -c "/usr/bin/google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder %U"

Exec=/usr/bin/google-chrome-stable -- bash -c "--use-gl=desktop --enable-features=VaapiVideoDecoder %U"

Exec=/usr/bin/google-chrome-stable "--use-gl=desktop" "--enable-features=VaapiVideoDecoder" %U

Exec=/usr/bin/google-chrome-stable --use-gl desktop --enable-features VaapiVideoDecoder %U

Ничего не помогает.

thechuprov ()
Ответ на: комментарий от thechuprov

Exec не понимает sh/bash, создай скрипт со всеми ключами и уже его указывай в exec. Обычно ключи нормально воспринимаются, возможно, что не нравится «=» в ключах.

einhander ★★★★★ ()
Последнее исправление: einhander (всего исправлений: 3)
Ответ на: комментарий от thechuprov

У меня была проблема сделать ярлык для Minecraft в Steam. Steam использует только *.desktop-файлы. Не помню, то ли пробелы в имени файла ему не нравились, то ли он так же, как и у тебя, не видел параметры.

В итоге создал файл /home/zenitur/bin/minecraft.sh со следующим содержимым:

#!/bin/sh

java -jar /home/zenitur/bin/launcher.jar

И сделал ярлык уже на него. Теперь всё работает. И да, файл minecraft.sh должен иметь параметр исполняемого.

Даже не знаю, как Лёша Кластер сделал ярлыки для запуска NES-игр на NES Mini. Учитывая, что оболочка принимает только *.desktop файлы. И учитывая, что эмулятор надо запускать с параметрами. И учитывая, что у него мало опыта в линуксе.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от ZenitharChampion

Огромное спасибо за помощь! Теперь параметры передаются как надо.

thechuprov ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.