LINUX.ORG.RU

Прерывается звук при подключении к Wi-Fi

 , ,


0

2

Всем привет!

При подключении к Wi-Fi (и в процессе его дальнейшей работы) при просмотре видео, либо прослушивании аудио (случайно, раз в плюс-минус минуту) заикается звук. От плеера, не зависит. Вывод звука через PulseAudio, ALSA немного ухудшает ситуацию. Спасает только отключение от Wi-Fi (Lenovo T420, Debian 10, 4.19.0-13-amd64, Gnome3).

Полагаю, что это связано с обработкой прерываний от оборудования. Подскажите, что и где подкрутить.

Иван.

Полагаю, что это связано с обработкой прерываний от оборудования.

А еще Wi-Fi и Bluetooth работают на одних и тех же частотах, так что возможны взаимные помехи. Кроме того, весьма часто это один и тот же адаптер, и попробуй пойми как две технологии там вместе уживаются. Можно вручную перепробовать разные каналы в настройках роутера. Если стоит ширина полосы 40 МГц или авто, выставить 20. Можно перейти на Wi-Fi 5 ГГц: с ним вообще меньше проблем, а скорости – выше.

Bagrov ★★★★★ ()
Ответ на: комментарий от frolovia

Привет. Что-нибудь решилось за это время?

(У меня больше нет предположений, но я этим комментом я надеюсь поднять тему в трекере и тем самым призвать кого-нибудь, кто лучше разбирается в проблемах Linux на десктопе.)

Bagrov ★★★★★ ()
Ответ на: комментарий от Bagrov
Ответ на: комментарий от Bagrov

Зашел на форум только 13-го.

В соответствии с последним коментарием, добавление tsched=0

/etc/pulse/default.pa
load-module module-udev-detect tsched=0

разрешило ситуацию. Потестирую, если будут проблемы — отпишусь. [Всем] спасибо за участие!

frolovia ()