LINUX.ORG.RU

Как успокоить nvidia?

 , ,


0

1

Есть затычка 1050. Если ничего не делать(не шевелить курсором), то частоты 139,405. Если что-то начать делать(выделить текст в терминале или что-то еще), то прыгает сразу на 398,405. Если в броузере открыть новую вкладку и загрузить что-нибудь, сразу 1379,3504(по идее максимальная частоты gpu,ram)

В .xinit

export __GL_SYNC_TO_VBLANK=1 &
export __GL_YIELD="USLEEP" & # disable tiring
set vblank_mode=1 &
nvidia-settings --assign [gpu:0]/GPUOverclockingState=1 &
nvidia-settings --assign [gpu:0]/GPUPowerMizerMode=2 &
nvidia-settings --assign [gpu:0]/SyncToVBlank=1 &
nvidia-settings --assign [gpu:0]/FXAA=1 &

Это вообще нормально, что не работает 3d, а видеокарта начинает работать на максимальных частотах? Может что-то я неправильно настроил?

https://forums.developer.nvidia.com/t/solved-forcing-maximum-power-saving-on-the-desktop-minimum-power-mode-for-powermizer/30403

Но не хотелось бы ей ставить фиксированную частоту, хотелось бы ограничить максимальную или что еще лучше сделать так, чтобы она прыгала в максимум только на 3d

★★★★

В видеокартах уже давно нет понятия «не работает 3D», у них чисто физически больше нет блоков 2D-ускорения. Последние были Radeon HD4xxx, если не изменяет память.

anonymous ()
Ответ на: комментарий от Ford_Focus

Так тебе не WebGL надо выключать, а аппаратное ускорение. И ограничивать количество процессов. Всё это есть в нормальных настройках и не надо изображать из себя какира, ломая about:config.

ChekPuk ★★★ ()

Ну это не техническая, а психологическая проблема.

Так то единственное, что важно — это кулера начинают выть или нет. Если нет, то всё равно.

fornlr ★★★★★ ()

nvidia-settings не нужен! да он прилетает с зависимостях к nvidia-driver, но потом его спокойно удалить можно, а блоб продолжит работать как ни в чем не бывало… проверено на всяком говне 630, 720, 750, 660ti, 1030

anonymous ()