LINUX.ORG.RU

Как установить пятый вайн? Debian 10.2 64-разрядный.

 , , ,


0

1
  1. Снёс wine 4.0.

Зашёл на ихний сайт

  1. wget -nc https://dl.winehq.org/wine-builds/winehq.key && sudo apt-key add winehq.key сделал

  2. require libfaudio0 as a dependency Скачал deb для amd64 и i386 и, вроде, установил.

  3. deb https://dl.winehq.org/wine-builds/debian/ buster main в sources.list сделал.

c@c-desktop:~/wine-dirs/wine-source$ sudo apt install –install-recommends winehq-stable

Чтение списков пакетов… Готово

Построение дерева зависимостей

Чтение информации о состоянии… Готово

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,

неосуществимо, или же вы используете нестабильную версию дистрибутива, где

запрошенные вами пакеты ещё не созданы или были удалены из Incoming.

Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:

winehq-stable : Зависит: wine-stable (= 5.0.0~buster)

E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Застрял.

Из исходников тоже не вышло:

c@c-desktop:~/wine-dirs/wine-source$ ./configure
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking for ld... ld
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

Как надо-то?

★★★

Ответ на: комментарий от RedEyedMan666

И потом ищи говно придумку хаиповщиков типа через наш протон dxvk 1000 фпс сразу и звук не заикается, знаем проходили. Тут уж надо как то попробовать наоборот собрать плауонлинукс либо опять вино попробовать в 16.04 пересобрать кстати пакет во все дебиано подобные дистры подходит.

anonymous ()
Ответ на: комментарий от anonymous

И потом ищи говно придумку хаиповщиков типа через наш протон dxvk 1000 фпс сразу и звук не заикается, знаем проходили.

Не нравится – не пользуйся. Чего бухтеть. Если у тебя атом вместо процессора, то звук будет заикаться :)

Ты и собрать-то не можешь. А еще бухтишь. Для неосиляторов уже все собрано. Осталось только зайти на сайт POL. :D

dxvk 1000 фпс

На твоем-то корыте, где даже звук заикается? Петросян.

RedEyedMan666 ()
Ответ на: комментарий от RedEyedMan666

В 16.04 всё идёт быстрее это единственная система где я видел самую быструю отдачу от ваина где графика оказалась даже быстрее чем в Винде именно в directx не говоря уже об opengl всё на этом история кончается и начинается век приключении и набирания васьков в калононикал на высокие зарплаты что бы убить весь 2.7 питон и продать его наверное андроиду что бы поживиться , нам тут не говорят что там за кулисами происходит , но разницу видно.

anonymous ()
Ответ на: комментарий от anonymous

В 16.04 всё идёт быстрее это единственная система где я видел самую быструю отдачу от ваина где графика оказалась даже быстрее чем в Винде именно в directx

Полный бред. Это не вайн быстрый в убунточках, а графический стек в ней свежее и собран с оптимизациями.

даже быстрее чем в Винде именно в directx

С некоторыми заглушками в вайне :)

RedEyedMan666 ()
Ответ на: комментарий от RedEyedMan666

Все просто возможно благодаря тому что туда ещё не засунули питон 3. Не думаю что оболочки в плане помех скорости отрисовки мешают буть то кути 100500 или гтк 15 , весь секрет питон 2.7. Тем более так совпало что дистр был удачно смешан.

anonymous ()

Как же здорово всё-таки после Убунты живётся в арче. Набрал в консоли pacman -S wine (или yay wine), оно скачалось, и у тебя свежий пятый Вайн 🧐

anonymous ()
Ответ на: комментарий от anonymous

Арч принципиально не люблю так как шлак я с помощью make все так же могу делать и его нельзя запаковать через убикьюлити и он ломается просто тупо од модификации у вас уже есть этот файл пам парам пам пам , а если я тысячу их перекинул приди разберись деб же на ура все аккуратно в info

anonymous ()
Ответ на: комментарий от Korchevatel

После 3 шага надо было сделать sudo apt update && sudo apt upgrade, дабы подтянулся новый список пакетов (или как там).

Не помогло

c@c-desktop:~/wine-dirs/wine-source$ sudo apt update && sudo apt upgrade
[sudo] пароль для c: 
Сущ:1 http://ftp.ru.debian.org/debian buster InRelease
Сущ:2 http://ftp.ru.debian.org/debian buster-updates InRelease                                                                     
Сущ:3 http://ftp.ru.debian.org/debian buster-backports InRelease                                                                                                           
Сущ:4 http://security.debian.org/debian-security buster/updates InRelease                                                                                                  
Сущ:5 https://dl.winehq.org/wine-builds/debian buster InRelease                                                                    
Чтение списков пакетов… Готово            
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Все пакеты имеют последние версии.
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  cabextract fuseiso libcapi20-3 libmspack0 libodbc1 libosmesa6 libvkd3d1 libwine wine64
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
c@c-desktop:~/wine-dirs/wine-source$ sudo apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты будут УДАЛЕНЫ:
  cabextract fuseiso libcapi20-3 libmspack0 libodbc1 libosmesa6 libvkd3d1 libwine wine64
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 9 пакетов, и 0 пакетов не обновлено.
После данной операции объём занятого дискового пространства уменьшится на 237 MB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 195442 файла и каталога.)
Удаляется cabextract (1.9-1) …
Удаляется fuseiso (20070708-3.2+b1) …
Удаляется libcapi20-3:amd64 (1:3.27-3) …
Удаляется libmspack0:amd64 (0.10.1-1) …
Удаляется libodbc1:amd64 (2.3.6-0.1) …
Удаляется libosmesa6:amd64 (18.3.6-2) …
Удаляется wine64 (4.0-2) …
Удаляется libwine:amd64 (4.0-2) …
Удаляется libvkd3d1:amd64 (1.1-3) …
Обрабатываются триггеры для man-db (2.8.5-2) …
Обрабатываются триггеры для libc-bin (2.28-10) …
c@c-desktop:~/wine-dirs/wine-source$ sudo apt install --install-recommends winehq-stable
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 winehq-stable : Зависит: wine-stable (= 5.0.0~buster)
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
c@c-desktop:~/wine-dirs/wine-source$
tiinn ★★★ ()
# dpkg --add-architecture i386
$ wget -nc https://dl.winehq.org/wine-builds/winehq.key
# apt-key add winehq.key
# nano /etc/apt/sources.list
deb https://dl.winehq.org/wine-builds/debian/ buster main
# apt update 
# apt install --install-recommends winehq-devel
$ winecfg
amd_amd ★★ ()

Узнали бы насчет темы хотя бы перед тем как давать советы, товарищи лороводы.

Тебе нужен FAudio. Нынче без него WINE не пашет.

В минте/убунту просто надо добавить репу:

sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport

В дебиане наверное надо поставить самому(Вот ссылочка)

https://forum.winehq.org/viewtopic.php?f=8&t=32192

Qurao ()
Ответ на: комментарий от amd_amd

c@c-desktop:~$ sudo dpkg --add-architecture i386 [sudo] пароль для c:

c@c-desktop:~$ wget -nc https://dl.winehq.org/wine-builds/winehq.key
Файл «winehq.key» уже существует — не загружается.

c@c-desktop:~$ nano /etc/apt/sources.list

Сущ:1 http://security.debian.org/debian-security buster/updates InRelease
Сущ:2 http://ftp.ru.debian.org/debian buster InRelease
Сущ:3 http://ftp.ru.debian.org/debian buster-updates InRelease
Сущ:4 http://ftp.ru.debian.org/debian buster-backports InRelease                                  
Сущ:5 https://dl.winehq.org/wine-builds/debian buster InRelease                                   
Чтение списков пакетов… Готово            
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Может быть обновлено 2 пакета. Запустите «apt list --upgradable» для их показа.
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 winehq-devel : Зависит: wine-devel (= 5.0.0~buster)
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
tiinn ★★★ ()
Последнее исправление: tiinn (всего исправлений: 1)

winehq-stable : Зависит: wine-stable (= 5.0.0~buster)

sudo apt install wine-stable

Потом так же тыкаешься в его зависимость. В итоге дойдёшь до пакета, которого нет, скорее всего, это один из кусков faudio.

anonymous ()
Ответ на: комментарий от tiinn

Да, попробуй. Я ставил на стретч, но давно, это ещё не пятый вайн был…

Но сейчас там сборки свежие, судя по датам. Можно и Самого скастовать, кстати. :)

hobbit ★★★★★ ()

Как установить пятый вайн? Debian 10.2 64-разрядный

Как установить пятый вайн? Debian 10.2 64-разрядный

Разобрался (не до конца).

  • Идём сюда https://github.com/FNA-XNA/FAudio, скачиваем и компилируем FAudio: mkdir build/ ; cd build/ ; cmake ../ ; make
  • Запускаем checkinstall и указываем имя пакета во втором пункте - libfaudio0, затем указываем номер версии: 20.02.00 (или какая у Вас будет на момент установки, добавляя .00). По инструкциям далее устанавливаем пакет libfaudio.
  • Добавляем репозиторий, как написано здесь - https://wiki.winehq.org/Debian, на забываем дать в конце команду apt update.
  • Последний шаг - устанавливаем wine следующей командой: apt install wine-stable-amd64
  • Думал это всё, оказалось - нет. wine установился частично в /opt/wine-stable; команда apt install --install-recommends winehq-stable выдаёт: Следующие пакеты имеют неудовлетворённые зависимости: winehq-stable : Зависит: wine-stable (= 5.0.0~buster).

    Если кто-то победит, пожалуйста, отпишитесь...

    PS: Кажется понял, проблема в следующем:
    apt-get install wine-stable-i386 выдаёт:

    wine-stable-i386:i386 : Зависит: libfaudio0:i386 (>= 19.06.07) но он не может быть установлен.

    Т.е. надо компилировать libfaudio0:i386. Как это сделать на ПК-amd64 я не знаю. По ссылке есть инструкция, но с этим возиться как-то не очень хочется.

    Примечание: в Минте (Ubuntu 16.04) установился без проблем, в Debian 10 почему-то танцы с бубном по инструкции выше. Почему так? Кто его знает...
Windows ★★ ()
Последнее исправление: Windows (всего исправлений: 6)

Как установить пятый вайн? Debian 10.2 64-разрядный

Добил. На официальном сайте рекомендуют скачать библиотеку FAudio для i386 и amd64:

1. libfaudio0_i386: wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18...

Если ссылка не работает, ищите последнюю версию здесь

2. libfaudio0_amd64: wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18...

Если ссылка не работает, ищите последнюю версию здесь

Потом просто действуем по инструкции - https://wiki.winehq.org/Download

Windows ★★ ()
Последнее исправление: Windows (всего исправлений: 3)