LINUX.ORG.RU

Debian sid, требуется libjpeg.so.8

 , ,


0

1

Для запуска nQuake требуется libjpeg.so.8

Симлинк с девятой не помогает

root@debian:/home/deepforest/nquake# ./ezquake-linux-x86_64
./ezquake-linux-x86_64: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory

root@debian:/home/deepforest/nquake# 
root@debian:/usr# ln -s /usr/lib/x86_64-linux-gnu/libjpeg.so.9 /usr/lib/libjpeg.so.8
root@debian:/usr# 
root@debian:/home/deepforest/nquake# ./ezquake-linux-x86_64
./ezquake-linux-x86_64: /lib/libjpeg.so.8: version `LIBJPEG_8.0' not found (required by ./ezquake-linux-x86_64)

root@debian:/home/deepforest/nquake# 

Deleted

Помню были с этим проблемы в Stretch, ставил от Джесси, а сейчас только такую тухлятину для Дебиана нашел https://pkgs.org/download/libjpeg8

Twissel ★★★★★ ()
Ответ на: комментарий от Deleted

Распакуй и помести в /usr/lib/x86_64-linux-gnu/.

Лучше не загаживать системный RO каталог, а сделать рядом с исполняемым файлом каталог lib, в который поместить нужную *.so’шку.

Ну а дальше либо сделать скрипт run.sh, либо -Wl,--rpath’ом пройтись по бинарю.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

Лучше не загаживать системный RO каталог,

Обычно да. Но в этом случае (libjpeg.so.8 в дистре ТС нет и не будет), можно не заморачиваясь, положить данную либу в стандартный каталог.

Deleted ()
Ответ на: комментарий от Deleted

Это хорошо. Тоже сталкивался с этой байдой.

Ставь отметку «решено», короче, сам знаешь... чай не маленький уже :-)

Twissel ★★★★★ ()

Зачем брать самую нестабильную версию самого стабильного дистрибутива, когда можно было взять убунту.

rumgot ★★★★★ ()
Ответ на: комментарий от rumgot

Чисто интересно как люди сидят на таком. А так да, уже прихожу к тому, что Убунта это и есть баланс между стабильностью и свежестью.

Deleted ()
Ответ на: комментарий от Deleted

прихожу к тому, что Убунта это и есть баланс между стабильностью и свежестью.

Поправка: Убунта - система на пол года (максимум на год). Вышла новая версия - старую сноси, новую накатывай с нуля, иначе огребёшь.

Deleted ()
Ответ на: комментарий от Deleted

Всмысле криво ставятся обновы?

В смысле что-то обязательно ломается, причём так, что проще установить с «нуля», чем разгребать.

Deleted ()
Ответ на: комментарий от Deleted

Вот блин и тут засада. Да, правда. Обновлял знакомому, было куча граблей. Есть ли решение? Что ты сам пользуешь?

Deleted ()
Ответ на: комментарий от Deleted

В смысле что-то обязательно ломается, причём так, что проще установить с «нуля», чем разгребать.

А сделать так чтобы обновы ничего не ломали никак нельзя?

Deleted ()
Ответ на: комментарий от Deleted

Боюсь, что не вылезу из вечной настройки системы

Именно поэтому пользую Debian.

Deleted ()
Ответ на: комментарий от Deleted

А сделать так чтобы обновы ничего не ломали никак нельзя?

С ubuntu - нет. Это даже не testing.

Deleted ()
Ответ на: комментарий от Deleted

Хз, по-моему там просто по дефолту много чего сломано(qtcreator и gvim только чего стоят)

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.