LINUX.ORG.RU

Debian + amd + sddm = fail

 , ,


0

2

Debian buster. Свежая установка из netinstall (точнее даже две установки) с KDE рабочим столом. Оба раза одно и тоже - после установки сервис sddm работает, фейлов нет, но иксы не стартуют, ДМ не появляется. Дрова стоят, фирмварь стоит.

Лог иксов - https://pastebin.com/UEhmaZjh

/dev/fb0 существует. Конфига xorg.conf по умолчанию нет. Генерация конфига с указанием busid ситуацию не меняет. Пробовал переустанавливать иксы, дрова и фирмварь. По lspci карта и драйвер определяются.

С nomodeset та же история. ЧЯДНТ?

[    10.395] (II) Loading /usr/lib/xorg/modules/drivers/[u]modesetting_drv[/u].so
[    10.395] (II) Module modesetting: vendor="X.Org Foundation"
[    10.395]    compiled for 1.20.3, module version = 1.20.3
[    10.395]    Module class: X.Org Video Driver
[    10.395]    ABI class: X.Org Video Driver, version 24.0
[    10.395] (II) LoadModule: "fbdev"
[    10.395] (II) Loading /usr/lib/xorg/modules/drivers/[u]fbdev_drv[/u].so
[    10.396] (II) Module fbdev: vendor="X.Org Foundation"
[    10.396]    compiled for 1.20.0, module version = 0.5.0
[    10.396]    Module class: X.Org Video Driver
[    10.396]    ABI class: X.Org Video Driver, version 24.0
[    10.396] (II) LoadModule: "vesa"
[    10.396] (II) Loading /usr/lib/xorg/modules/drivers/[u]vesa_drv[/u].so

Я вижу, что у тебя для xorg-server только три драйвера и драйвера radeon или amdgpu среди них нет.

Ставь драйвер.

anonymous ()
Ответ на: комментарий от Lithium

По lspci у тебя показывается драйвер (модуль) ядра.

А вот по логам драйвер для xorg-server у тебя не загружается.

Покажи содержимое:

ls /usr/lib/xorg/modules/drivers

anonymous ()
Ответ на: комментарий от Lithium

Ну и покажи вывод:

dpkg -l | grep -i 'radeon\|ati\|amd'

А заодно залей на pastebin вывод

dmesg

Ну и показывай вывод:

lspci -k
lsmod
В тегах [code][/code].

anonymous ()
Ответ на: комментарий от anonymous
ii  firmware-amd-graphics                         20190114-1                         all          Binary firmware for AMD/ATI graphics chips
ii  libdrm-amdgpu1:amd64                          2.4.97-1                           amd64        Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  xserver-xorg-video-amdgpu                     18.1.99+git20190207-1              amd64        X.Org X server -- AMDGPU display driver
26:00.0 0300: 1002:67df (rev c7) (prog-if 00 [VGA controller])
	Subsystem: 1462:3413
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f0000000 (64-bit, prefetchable) [size=2M]
	I/O ports at f000 [disabled] [size=256]
	Memory at fe900000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at fe940000 [disabled] [size=128K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Capabilities: [200] #15
	Capabilities: [270] #19
	Capabilities: [2b0] Address Translation Service (ATS)
	Capabilities: [2c0] Page Request Interface (PRI)
	Capabilities: [2d0] Process Address Space ID (PASID)
	Capabilities: [320] Latency Tolerance Reporting
	Capabilities: [328] Alternative Routing-ID Interpretation (ARI)
	Capabilities: [370] L1 PM Substates
	Kernel modules: amdgpu
edac_mce_amd           28672  0
kvm_amd               106496  0
kvm                   729088  1 kvm_amd
ccp                    98304  1 kvm_amd
amdgpu               3428352  0
chash                  16384  1 amdgpu
gpu_sched              28672  1 amdgpu
i2c_algo_bit           16384  1 amdgpu
ttm                   126976  1 amdgpu
drm_kms_helper        204800  1 amdgpu
drm                   483328  4 gpu_sched,drm_kms_helper,amdgpu,ttm
gpio_amdpt             16384  0
gpio_generic           16384  1 gpio_amdpt

Dmesg - https://pastebin.com/P7WgqzcM

Lithium ()
Ответ на: комментарий от Lithium
[    0.955682] [drm] amdgpu kernel modesetting enabled.
[    0.955757] [drm:amdgpu_pci_probe [amdgpu]] *ERROR* amdgpu requires firmware installed
[    0.955781] See https://wiki.debian.org/Firmware for information about missing firmware

Вижу, что пакет https://packages.debian.org/search?keywords=firmware-amd-graphics стоит.

Но в логах всё равно есть сообщение о прошивках.

Arctic Islands	POLARIS10	RX 470, RX 480, RX 570, RX 580	amdgpu/polaris10_{ce,ce_2,k_smc,k_mc,mc,me,me_2,mec2,mec2_2,mec,mec_2,pfp,pfp_2,rlc,sdma1,sdma,smc,smc_sk,uvd,vce}.bin
POLARIS11	RX 460, RX 550 640SP, RX 560	amdgpu/polaris11_{ce,k_smc,k_mc,mc,me,mec2,mec,pfp,rlc,sdma1,sdma,smc,smc_sk,uvd,vce}.bin
POLARIS12	RX 540, RX 550	amdgpu/polaris12_{ce,ce_2,k_mc,k_smc,mc,me,me_2,mec,mec2,mec2_2,mec_2,pfp,pfp_2,rlc,sdma,sdma1,smc,uvd,vce}.bin

В зависимости от модели твоей видео карты проверь, что они точно есть в /lib/firmware/amdgpu*.

anonymous ()
Ответ на: комментарий от anonymous

xorg.conf генерить пробовал, потом удалил. В xorg.conf.d нет.

Lithium ()
Ответ на: комментарий от anonymous

Я об этом и говорю. Дрова есть, модуль загружается, фирмварь есть. Только графики нет…

Lithium ()
Ответ на: комментарий от anonymous

У меня 570. Она поддерживается. У меня прямо сейчас в дуалбуте дебиан стретч с таким же сетапом. Там все работает без проблем. Что-то поломали в бастере, я думаю.

Lithium ()
Ответ на: комментарий от Lithium

Что-то поломали в бастере, я думаю.

Тогда пиши баг репорт.

Ну и как я сказал посмотри содержимое /lib/firmware/amdgpu/

ls /lib/firmware/amdgpu/polaris10*
Можешь для теста скопировать содержимое /lib/firmware/amdgpu/ из Stretch в Buster.

Ну и посмотри:

ldd /путь_до_so_файла/amdgpu_drv.so

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.