LINUX.ORG.RU

Gentoo не работает звук

 , ,


0

1

Недавно решил поставить Gentoo и все работает отлично, кроме звука. Он не работает вообще.

Выхлоп lspci | grep -i audio:

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

Выхлоп alsamixer:

cannot open mixer: No such file or directory

Выхлоп aplay -l:

aplay: device_list:272: no soundcards found…

Выхлоп ls /sys/class/sound/:

seq timer

USE флаг alsa есть

Пользуюсь 00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

*Ядро конфижил сам

Ответ на: комментарий от anonymous
[    1.303051] snd_hda_intel 0000:01:00.1: Disabling MSI
[    1.313754] hdaudio hdaudioC0D2: Unable to bind the codec
[    1.548784] hdaudio hdaudioC1D0: Unable to bind the codec
[    1.549117] hdaudio hdaudioC1D1: Unable to bind the codec
[    1.549424] hdaudio hdaudioC1D2: Unable to bind the codec
[    1.549731] hdaudio hdaudioC1D3: Unable to bind the codec
clstrmstr ()
Ответ на: комментарий от clstrmstr

У тебя или чисто hdmi-звуковуха, или ядро не поддерживает твою встройку, кодеков нет, нужно более новое ядро.

anonymous ()
Ответ на: комментарий от clstrmstr

Кодеки должны быть, т.к. раньше ставил gentoo и звук работал.

Что мешает сравнить конфиги? Или использовать старый через make oldconfig?

anonymous ()
Ответ на: комментарий от Kron4ek

От рута alsamixer запускается или такую же ошибку выдает?

У него карту система не определяет. Не собрал правильно ядрышко.


Для ТС - ползи на gentoo и смотри настройки для ALSA (там опции ядра вроде написаны) Плюс пользуйся поиском.

n1rdeks ()
Ответ на: комментарий от n1rdeks

CONFIG_SND_HDA_PREALLOC_SIZE и тут впили 2048 для совместимости.
Ну да просто учись собирать ядро ))) Заодно будешь знать свою конфу и изучишь опции ))

n1rdeks ()
Ответ на: комментарий от clstrmstr

Все уже было сделано

Нет-с
Было бы сделано - завелось бы.
первая опция «Dynamic device file minor numbers»
если не включена - карта не заводится.

n1rdeks ()
Ответ на: комментарий от clstrmstr

1458:a002

Походу реалтык ALC887, но могу и ошибаться. Если после сборки реалтыковского кодека звука не будет, попробуй добавить options snd-hda-intel model=generic в /etc/modprobe.d/alsa.conf

Meyer ★★★★ ()
Ответ на: комментарий от clstrmstr

У тебя скорее всего стоит какой-то запрет на загрузку сторонних firmware. Посмотри(отключи) CONFIG_STANDALONE, CONFIG_PREVENT_FIRMWARE_BUILD. Возможно после этого появятся новые кодеки, включи их. Установи emerge sys-kernel/linux-firmware

anonymous ()
Ответ на: комментарий от Meyer
/usr/src/linux/sound/pci/hda $ grep -i '1458.*a002' *
hda_intel.c:	SND_PCI_QUIRK(0x1458, 0xa002, "Gigabyte P55A-UD3 / Z87-D3HP", 0),
patch_realtek.c:	SND_PCI_QUIRK(0x1458, 0xa002, "GA-MA790X", 1),
patch_realtek.c:	SND_PCI_QUIRK(0x1458, 0xa002, "Gigabyte EP45-DS3/Z87X-UD3H", ALC889_FIXUP_FRONT_HP_NO_PRESENCE),
anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.