LINUX.ORG.RU

Gentoo + Intel C216 нет звука.

 , ,


0

1

Всем привет! Пытаюсь завести звук на вот такой карточке

# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

Звука нет, в kmix нет доступных звуковых устройств.

Опции ядра:

cat .config | grep "HDA"
CONFIG_SND_HDA=y
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
CONFIG_SND_HDA_CORE=y
CONFIG_SND_HDA_I915=y
CONFIG_SND_HDA_PREALLOC_SIZE=64

# aplay -l
aplay: device_list:268: no soundcards found...
# lspci -k
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
	Subsystem: Lenovo 7 Series/C216 Chipset Family High Definition Audio Controller
	Kernel driver in use: snd_hda_intel

Ответ на: комментарий от dpronyaev

Поставь пакет media-sound/alsa-utils и запусти alsamixer. Как сказали выше, там по дефолту стоит какой-нибудь hdmi. Выбери в миксере свою карту и все должно заработать из коробки.

anonymous ()
Ответ на: комментарий от anonymous

Installing (1 of 1) media-sound/alsa-utils-1.1.2::gentoo
Auto-cleaning packages...

No outdated packages were found on your system.

* GNU info directory index is up-to-date.

* IMPORTANT: 14 news items need reading for repository 'gentoo'. * Use eselect news read to view new items.

x230 ~ # alsamixer cannot open mixer: No such file or directory

dpronyaev ()
Ответ на: комментарий от Revent

# dmesg | grep snd_hda_intel [ 0.487113] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops 0xffffffffa389e1c0)

dpronyaev ()
Ответ на: комментарий от dpronyaev

# alsamixer cannot open mixer: No such file or directory

Alsamixer нужно запускать от пользователя, а не от рута. И твой пользователь при этом должен состоять в группе audio.

anonymous ()
Ответ на: комментарий от dpronyaev

aplay: device_list:268: no soundcards found...

А сама alsa точно запущена? Так то оно должно хотя бы один девайс находить (заглушку).

anonymous ()
Ответ на: комментарий от dpronyaev

Загрузись в Ubuntu Live и посмотри:

grep -i codec /proc/asound/card*/codec* 

kostik87 ★★★★★ ()
Ответ на: комментарий от dpronyaev

Проверь запущена ли служба альсы:

/etc/init.d/alsasound status

Если нет, то:

rc-update add alsasound default
/etc/init.d/alsasound start

anonymous ()
Ответ на: комментарий от anonymous

Оно. Запустил, добавил в default - заработало и до и после перезагрузки. Спасибо!

dpronyaev ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.