LINUX.ORG.RU

VLC (и не только) вешает систему

 , ,


0

3

Всем привет. Внезапно столкнулся со следующим. Всё зависает, стоит только запустить VLC. При чем можно даже без видео - просто vlc, и система виснет.

Сначала секунд на 5-10 зависает все, включая курсор. Потом курсор отвисает и двигается, но ничего нажать нельзя, на экране картинка как зависла так и не меняется, клавиатура тоже не реагирует. В это время есть возможность залогиниться по ssh, и допустим убить процесс vlc (ничего не меняется, даже окно не пропадает), X-сервер (выбросит в консоль, но клавиатура все так же не работает), поделать что-то ещё. В целом, помогает только перезагрузка. В dmesg - ничего, в логах тоже ничего не нашел.

Воспроизводится 100% стабильно с VLC (даже без видео), но если допустим включить видео в mplayer, то в какой-то момент всё тоже зависает, просто не сразу - может, через полминуты.

Система - gentoo, ядро 4.18.3-gentoo, пробовал также 4.16.13-gentoo. Ноутбук ThinkPad W530, i7-3740QM, интегрированная видеокарта intel, установлено x11-drivers/xf86-video-intel-2.99.917_p20180214-r1. Версия VLC 3.0.4, но т.к. воспроизводится и с mplayer, думаю дело не в нем.

Хардварная проблема маловероятна: переставил диски в другой ноутбук (T420, тоже встройка intel), то же самое.

Что это может быть, как дебажить?


ставь calculate linux

таже гента но собрана правильно, и будет счастье

(а так ты просто собрал с неверными опциями ядра/иксов/дров интела и все)

missxu ()
Ответ на: комментарий от annerleen

Меньше кода. Является частью X.org, поэтому всегда имеет актуальную версию ABI. Иногда работает быстрее intel. Так как использует 3d движок, не наступает на грабли, которые собирает драйвер intel. (И наоборот.)

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

А как узнать, что сейчас используется, xf86-video-intel или modesetting?

xserver-xorg-video-intel установлен, но в Xorg.0.log видно, что modesetting тоже загружается:

[    42.537] (**) |   |-->Device "Intel Graphics"
[    42.562] (II) LoadModule: "intel"
[    42.562] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    42.564] (II) Module intel: vendor="X.Org Foundation"
[    42.564] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
[    42.564] (II) intel: Driver for Intel(R) HD Graphics
[    42.564] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    42.564] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    42.580] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180921
[    42.581] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20180925-2 (Andreas Boll <aboll@debian.org>)
[    42.581] (II) intel(0): SNA compiled for use with valgrind
[    42.594] (--) intel(0): gen9 engineering sample
[    42.594] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[    42.594] (II) intel(0): Creating default Display subsection in Screen section
[    42.594] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    42.594] (==) intel(0): RGB weight 888
[    42.594] (==) intel(0): Default visual is TrueColor
[    42.594] (**) intel(0): Option "DRI" "3"
[    42.595] (**) intel(0): Option "SwapbuffersWait" "0"
[    42.596] (II) intel(0): Output eDP1 has no monitor section
[    42.603] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    42.603] (II) intel(0): Enabled output eDP1
[    42.603] (II) intel(0): Output DP1 has no monitor section
[    42.603] (II) intel(0): Enabled output DP1
[    42.603] (II) intel(0): Output HDMI1 has no monitor section
[    42.603] (II) intel(0): Enabled output HDMI1
[    42.603] (II) intel(0): Output DP2 has no monitor section
[    42.603] (II) intel(0): Enabled output DP2
[    42.603] (II) intel(0): Output HDMI2 has no monitor section
[    42.603] (II) intel(0): Enabled output HDMI2
[    42.603] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    42.603] (II) intel(0): Output VIRTUAL1 has no monitor section
[    42.603] (II) intel(0): Enabled output VIRTUAL1
[    42.603] (--) intel(0): Output eDP1 using initial mode 2560x1440 on pipe 0
[    42.604] (==) intel(0): TearFree enabled
[    42.604] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[    42.604] (==) intel(0): DPI set to (96, 96)
[    42.607] (II) intel(0): SNA initialized with Kabylake (gen9) backend
[    42.607] (==) intel(0): Backing store enabled
[    42.607] (==) intel(0): Silken mouse enabled
[    42.607] (II) intel(0): HW Cursor enabled
[    42.607] (==) intel(0): DPMS enabled
[    42.607] (==) intel(0): Display hotplug detection enabled
[    42.608] (II) intel(0): [DRI2] Setup complete
[    42.608] (II) intel(0): [DRI2]   DRI driver: i965
[    42.608] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    42.608] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[    42.608] (II) intel(0): hardware support for Present enabled
[    42.636] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    42.637] (II) intel(0): Setting screen physical size to 677 x 381
[    42.710] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event9)
[    42.710] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event10)
[    42.711] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event11)
[    42.711] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=7 (/dev/input/event12)
[    42.711] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=8 (/dev/input/event13)
[    42.712] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=9 (/dev/input/event14)
[    42.712] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=10 (/dev/input/event15)
[    44.605] (II) intel(0): EDID vendor "LGD", prod id 1419
[    44.605] (II) intel(0): Printing DDC gathered Modelines:
[    44.605] (II) intel(0): Modeline "2560x1440"x0.0  241.69  2560 2608 2640 2720  1440 1450 1455 1481 +hsync -vsync (88.9 kHz eP)
[    77.152] (II) LoadModule: "modesetting"
[    77.152] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    77.152] (II) Module modesetting: vendor="X.Org Foundation"
[   152.368] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   200.891] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[124395.130] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[232792.406] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[276945.676] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[281664.162] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[300273.141] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[304890.538] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none

annerleen ★★★ ()