LINUX.ORG.RU

Ошибка при установке VMware Player 14 на Ubuntu 18.04

 , ,


0

1

Беру bundle с оффсайта, даю права на исполнение, запускаю через sudo. Начинается графический setup, жму далее-далее, в конце ошибка - Installation was unsuccessful. Погуглил, нашел - https://kb.vmware.com/s/article/2058527 Запустил установщик через терминал, два раза согласился на лицензию, ошибка та же Installation was unsuccessful. Пробовал разные минорные версии внутри 14 - результат тот же. Какие варианты?

Слишком свежее ядро, вмтварь этим давно грешит

Lordwind ★★★★★ ()
Ответ на: комментарий от chenbr0

Кхм, вам сказали, что в вашем дистрибутиве, возможно, новое ядро, под которое установщик VMPlayer 14 не может собрать модули ядра.

Зачем вы пробуете ставить ещё более старую версию, VMPlayer 12? Он точно не соберёт модули под новое ядро, т.к. как он ещё более старый.

Пробуйте ставить Oracle VirtualBox, ну либо ждите пока в VMWare исправят сборку модулей под новые ядра.

А так, найдите файл лога, в котором написано на каком этапе обрывается установка.

anonymous ()

Репозитории?

 sudo apt install программа/назввание

BLIN4IK97 ()
Ответ на: комментарий от BLIN4IK97

Из-за лицензионных ограничений VMware нет ни в одном репозитории. Только качать с сайта и ручками, приняв EULA. Причину уже объяснили — ядро 4.15 слишком ново для этого ПО.

Vsevolod-linuxoid ★★★★★ ()
vasia$ sudo bash
# sh ./VMWare-bundle-installer




Но да, я не пробовал. если ядро не подходит, то бедя

Deleted ()
Ответ на: комментарий от Deleted

на свежую убунту 18.04 (с апдейтами) накатил VMW-workstation, свежескачанную с сайта.

всё робит. ведро по-дефолту, ничего не менял, 4.15.33 шоле.

Deleted ()
Ответ на: комментарий от Deleted

Только что обновился, 4.15.0-33-generic. Ничего не изменилось.

chenbr0 ()
Ответ на: комментарий от chenbr0
vasya$ cp ~/Загрузки/VMware-14-*.bundle /tmp
vasya$ sudo bash
# cd /tmp
#chmod +x ./VMware-14-*.bundle
#xhost +
#sh ./VMware-14-*.bundle
Deleted ()
Последнее исправление: RTP (всего исправлений: 1)
Ответ на: комментарий от Deleted

То же самое. Ладно, видимо линукс все таки не для десктопа.

chenbr0 ()
Ответ на: комментарий от chenbr0

щас с ходу не вспомню, но надо установить kernel-devel и прочие компиляторы.

я тут прикинул, что у меня дрыйвер невидии установлен, может он чего подтягивает в плане компилянья модулей для ядра.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.