LINUX.ORG.RU

kmix + pulseaudio нет настройки баса

 , , ,


0

1

Здравствуйте

Переехал на pulseaudio, теперь в kmix только один ползунок, типа Master, но это не он, так как он не только управляет мастером, но и сбрасывает Front и Bass на 100%, что мне не нужно.

Вопрос. Можно ли вернуть функционал? (возможно что то нужно доустановить)

либо, Как отключить это сбрасывание баса на 100% при регулировки звука (нужно примерно 80% всегда)?

в alsamixer все работает (но нет хоткеев)

в alsamixer все работает

тогда повесь хоткеи на alsamixer/amixer

Deleted ()

Если у тебя DE не GNOME3, могу рассказать как выключить PulseAudio.

А вообще, скорее бы Red Hat решил что «пульса не нужна» и отодрал гвозди, которыми он прибил её к этому DE.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Deleted

Да, я до этого пункта то дошёл и утомительно вручную выбирал то, что нужно установить. А скажи, как там с зависимостями? Всё тоже вручную?

burato ★★★★★ ()
Ответ на: комментарий от burato

Мне как раз не надо из коробки

я делал по инструкции с сайта арча, но захлебнулся в ошибках

Очередной мамкин хакирь-поптимизатор)))

anonymous ()
Ответ на: комментарий от Deleted

Тогда повременить пока надо, я ещё недостаточно опытен.

burato ★★★★★ ()

опять пожалел что создал на лоре тему

только один человек написал что-то по существу, остальные ответы нужно удалить

brothermechanic ★★★★★ ()
Последнее исправление: brothermechanic (всего исправлений: 1)
Ответ на: комментарий от ZenitharChampion

нужно не нужно...

мне PulseAudio теперь нужен

так как некоторые программы, которыми я пользуюсь завязаны на нем, поэтому и был вынужден установить, до этого был только alsa драйвер.

и вот в чем вопрос, это я в этом году установил, а все все дистры же лет 10 как на PulseAudio, не ужели нет ползунка баса до сих пор? (пусть не в kmix, главное чтоб хоткей повесить, на alsamixer я не знаю как это сделать)

brothermechanic ★★★★★ ()
Ответ на: комментарий от brothermechanic

у самого kmix не установлен, т.к. не нужен, но, как помню, в нём на каждый ползунок можно хоткеи установить.

на amixer примерно так:

.xbinkdekysrc

# vol mute «amixer set Master mute» m:0x10 + c:160 # vol up «amixer set Master 2dB+ unmute» m:0x10 + c:176 # vol dn «amixer set Master 2dB- unmute» m:0x10 + c:174

для пущей наглядности гугли amixer+hotkeys или keybinding

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)
Ответ на: комментарий от Deleted

вот спасибо! уже что-то

но сейчас провел тест, та же хрень, видимо дело не в kmix.

$ amixer sset Master 70% (это упрощенно то что вы посоветовали)

до команды (бас в норме) https://i.imgur.com/InmTRKr.jpg

после команды (бас опять по максимуму) https://i.imgur.com/9X2AvGS.jpg

это баг?

brothermechanic ★★★★★ ()
Ответ на: комментарий от brothermechanic

это баг?

не могу ничего путного сказать, т.к не имею таких сложних настроек.

попробуй при измемение громкости всегда выставлять «Bass Speak» на 70%, т.е. что-то типа

amixer sset Master 90% && amixer sset «Bass Speak» 70%

Deleted ()
Ответ на: комментарий от brothermechanic

Firefox от PulseAudio умеет быть отвязанным при помощи пересборки из исходного кода с параметром --enable-alsa. Skype умеет быть отвязанным от PulseAudio при помощи утилиты apulse.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)

сбрасывает Front и Bass на 100%

После настройки в alsamixer нужных значений, пробовал выполнить?:

# alsactl store

nvl ★★ ()
Ответ на: комментарий от brothermechanic

пробовал

$ amixer sset «Bass Speak» 70%
amixer: Unable to find simple control '«Bass',0

Во-первых, лучше указывать карту.
Во-вторых, имя нужно указывать в апострофах.

$ amixer -c 0 sset 'Bass Speak' 70%
имя посмотри в
$ amixer -c 0 scontrols

nvl ★★ ()
Ответ на: комментарий от ZenitharChampion

Ах они сволочи. Им платят деньги, а они ставят пользователя буквой Зю.

Ты попутал. Это школота, наслушавшаяся всяких полоумных любителей повыпиливать пол системы и подпереть все костылями, ставит себя буквой зю.

anonymous ()
Ответ на: пробовал от brothermechanic

Попробуй в /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf для Front и Bass поменять merge на ignore.

[Element Front]
;volume = merge
volume = ignore
$ pulseaudio -k
а после этого уже выставить значения и
# alsactl store

nvl ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.