LINUX.ORG.RU

PuTTY Xming и прокси.

 , ,


0

2

Всем доброго дня. Замучалась уже к чертям. Рассказываю как есть. Имеется ноутбук, у него сломана крышка, на нем стоит Elementary Os, раздает WiFi. Есть комп, на нем стоит Win8.0 На ноуте OpenSSH server, подключаюсь к нему через PuTTY, но одного терминального окна мне мало. Хочется окна видеть. На компе установила Xming и настроила. Всё работает, все отображается, шрифты, раскладка и т.д. Прокси не работает зараза. т.е. запускаю PuTTY, в нем - chromium-browser, тот запускается, но IP блин показывает провайдера, а на ноуте, в настройках системы, указан HTTP прокси сервер. Если подключиться к ноуту через TimeViewer и запустить Chromium, то он этот прокси использует. А через PuTTY нет, понимаете? как исправить? всю голову сломала.

Если нужен только браузер то посмотрите справку, у него через ключи можно прокси указать при запуске. А так нужно проверять как у вас прокси настроена, может информацию о ней браузер получает только когда запущен в графической сессии (ну то есть без проброса X, а когда внутри вашего DE).

micronekodesu ★★★ ()
Ответ на: комментарий от micronekodesu

.

В Chromium'е нет каких то собственных настроек прокси сервера, он использует прокси системы. Т.е. если в браузере я нажимаю настройки - прокси - то гном открывает системные настройки сети, где есть настройка прокси сервера. И вот там то, прокси сервер прописан. А вот если браузер запустить через PuTTY, то он эти настройки - не видит.

Viki_Mokka ()
Ответ на: . от Viki_Mokka

А если сделать

export {http,ftp,https,rsync}_proxy="http://proxyserver:port"
перед запуском chromium. И через ключ командной строки тоже можно

pawnhearts ★★★★★ ()
Последнее исправление: pawnhearts (всего исправлений: 1)
Ответ на: . от Viki_Mokka

Серьезно, нет?

$ chromium --help | grep proxy
       --proxy-server=host:port
              Specify the HTTP/SOCKS4/SOCKS5 proxy server to use for requests.
              the  options  dialog.   An  individual proxy server is specified
                [<proxy-scheme>://]<proxy-host>[:<proxy-port>]
              Where <proxy-scheme> is the protocol of the proxy server, and is
              If  the  <proxy-scheme>  is omitted, it defaults to "http". Also
                --proxy-server="foopy:99"
                    Use the HTTP proxy "foopy:99" to load all URLs.
                --proxy-server="socks://foobar:1080"
                    Use the SOCKS v5 proxy "foobar:1080" to load all URLs.
                --proxy-server="socks4://foobar:1080"
                    Use the SOCKS v4 proxy "foobar:1080" to load all URLs.
                --proxy-server="socks5://foobar:66"
                    Use the SOCKS v5 proxy "foobar:66" to load all URLs.
              It is also possible to specify a separate proxy server for  dif‐
              ferent URL types, by prefixing the proxy server specifier with a
                --proxy-server="https=proxy1:80;http=socks4://baz:1080"
                    Load https://* URLs using the HTTP proxy "proxy1:80".  And
                    URLs using the SOCKS v4 proxy "baz:1080".
       --no-proxy-server
              Disables  the proxy server.  Overrides any environment variables
       --proxy-auto-detect
              Autodetect proxy configuration.  Overrides any environment vari‐
       --proxy-pac-url=URL
              Specify  proxy autoconfiguration URL.  Overrides any environment

micronekodesu ★★★ ()
Ответ на: комментарий от micronekodesu

--proxy-server=«socks4://foobar:1080»

Сработало. Спасибо большое! Не думала что в терминале можно запустить браузер с «ключом». Спасибо еще раз =)

Viki_Mokka ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.