LINUX.ORG.RU

linux, Intel GPU, битые шрифты

 


0

0

www.linux.org.ru/images/17858/original.gif

Не видел подобного года с 2012-го.

В Ubuntu 17.10 опять вернулось.

Thinkpad T410s, i5-520M со встроенным видео, ядро 4.13.0-21-generic.

По моим наблюдениям проблемы проявляются не сразу и не при любых условиях. Замечено, что при подключении внешнего монитора (и даже после его последующего отключения) через некоторое время иксы начинают тормозить. Скроллинг, например, превращается в слайд-шоу и процесс xorg при этом сильно грузит CPU.

Возможно, самого подключения/отключения внешнего монитора недостаточно, ещё нужно отключить ноутбук от блока питания. Драйвера переходят/переводят железо в режим уменьшения производительности и потом из него не выводят? От тормозов иксов помогает только релогин или перезагрузка.

Теперь увидел «фирменную» фишку интеловских драйверов — битые шрифты, про которую уже почти успел забыть со времён Арча на EEE PC.

UPD: что касается тормозов иксов:

[ 40510.329] (II) intel(0): EDID vendor "LEN", prod id 16438
[ 40510.329] (II) intel(0): Printing DDC gathered Modelines:
[ 40510.329] (II) intel(0): Modeline "1440x900"x0.0  106.89  1440 1488 1520 1924  900 903 909 926 -hsync -vsync (55.6 kHz eP)
[ 40510.329] (II) intel(0): Modeline "1440x900"x0.0   89.26  1440 1488 1520 1740  900 903 909 1026 -hsync -vsync (51.3 kHz e)
[ 40515.096] (II) intel(0): resizing framebuffer to 1920x1080
[ 40515.162] (II) intel(0): switch to mode 1920x1080@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 42566.284] (EE) intel(0): Failed to submit rendering commands (No such file or directory), disabling acceleration.
Есть такой багрепорт https://bugs.freedesktop.org/show_bug.cgi?id=103509
И такой https://bugs.freedesktop.org/show_bug.cgi?id=103025

Ты правда не понял, что постишь свои проблемы не в тот раздел?

tailgunner ★★★★★ ()

Если у тебя проблема с ядром или видео, пости в Desktop. Если хочешь поныть о штабильности - пости в Talks.

tailgunner ★★★★★ ()

Перемещено tailgunner из tailgunner

Oh you!

Deleted ()

А ноут новый? Я что-то похожее видел на старом ноуте с глючным видео.

tailgunner ★★★★★ ()
Ответ на: комментарий от tailgunner

Ноут старый, T410s. Но до обновления на 17.10 я этого не видел.

Последний раз видел глюки со шрифтами в виде исчезающих или покорёженных символов на EEE PC лет 5 назад.

utf8nowhere ★★ ()
Ответ на: комментарий от utf8nowhere

Я бы поставил на аппаратный сбой - новая система ставит более требовательный режим, которые видео по старости уже не тянет.

tailgunner ★★★★★ ()

Тогда я посмотрел бы, что фирмварь грузится. ну и вообще - нет ли в логах сообщений об аппаратных проблемах.

tailgunner ★★★★★ ()

В Ubuntu 17.10 опять вернулось.

В LTS все работает? Смысл сидеть на новых, да еще и по-сути тестовых, сборках, имея старенькое железо?

petrosyan ★★★★★ ()
Ответ на: комментарий от petrosyan

Смысл сидеть на новых, да еще и по-сути тестовых, сборках, имея старенькое железо?

Ради более свежей версии DE в основном.

Ну и некоторого другого софта.

utf8nowhere ★★ ()

> Теперь увидел «фирменную» фишку интеловских драйверов — битые шрифты

Видел лишь раз битые шрифты на Intel GPU, при запуске программ BlackBerry (это производитель смартфонов) в среде Openbox.
Во всех осталных программах, консоль и X.org - не видел битых шрифтов.

Возможно, что в твоём случае, конфиги фонтов дефолтные и нужно их исправить на свой личный вкус и лад.

blitz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.