LINUX.ORG.RU

Ядро 4.14.10 не поддерживает Nvidia?

 , , ,


0

2

Перестали Ядра 4.14.10, 4.14.9 поддерживать Nvidia? обновил, видеокарту попросту не видит. Видеокарта Nvidia 920m, драйвер 387.34. Как победить проблему? Ждать обновления драйверов? P.s. На ядре 4.14.8 все работало идеально.

Штабильный дистрибутив со старым драйвером? У меня всё работает.

anonymous ()
Ответ на: комментарий от anonymous

Дистрибутив Xubuntu 16.04.3, дрова самые свежие. Именно на 4.14.10 перестало заводится. По команде prime-select qiery выдает unknown

Kenny3k ()
Ответ на: комментарий от Kenny3k

что там работало идеально? драйверы откуда-нибудь ещё устанавливал?

darkenshvein ★★★★★ ()
Ответ на: комментарий от Kenny3k

Так версия драйвера какая? У меня 387.34

anonymous ()

А что ты хотел от блоба? Т.к. у линукса нет стаблиного API драверов, т.к. у линукса нет стабильного API графического стека, то ни о каком смене ядра без команды nvidia говорить не приходится.

ox55ff ★★★ ()
Ответ на: комментарий от post-factum

спасибо, понял. Буду на 4.14.8 пока сидеть, пока не пофиксят)

Kenny3k ()

Нивидия проблемы. Жди пока новый бАнальный блоб выпустят с поддержкой свежих вёдер.

paran0id ★★★★★ ()
Ответ на: комментарий от paran0id

Просто надо сидеть на LTS, чтобы потом не жаловаться что опять сломали.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от I-Love-Microsoft

Да нет, достаточно просто на адекватном дистрибутиве, вот у меня не лтс, но всё работает.

anonymous ()

Вовремя я однако на AMD пересел.

SR_team ★★★★ ()
Ответ на: комментарий от Kenny3k

Я вообще дровину с офсайта качал, оно в DKMS само зарегалось и не слетает при обновлении вёдер, раз что когда совсем новую дичь выкатят.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от SR_team

Это глупости. С офсайта скачал раз в несколько лет - дальше через DKMS будет нормально подновляться. Никаких проблем на самом деле.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от SR_team

Это звучит сейчас сомнительно, учитывая технологическое отставание радеон груп.

anonymous ()
Ответ на: комментарий от Kenny3k

В ЛТС сейчас ядро 4.10. Обновился самостоятельно — будь добр следить за такими ситуациями сам.

ionanahin ★★★ ()

NVIDIA не пускает на новые ядра линуксоидов - так было всегда. Ждите, когда соблаговолит. (А вот на FreeBSD с этим нет проблем и полный кайф из-за обратной совместимости ABI/ядерного API).

iZEN ★★★★★ ()

А у меня на федоре даже 4.14.8 не работает с соответствующей нвидией из фьюжен репы, но 4.14.7 работает нормально.

sT331h0rs3 ★★★★★ ()

Сегодня ночью тоже обновился. С утра офигел) LTS называется.

th3m3 ★★★★★ ()
Последнее исправление: th3m3 (всего исправлений: 1)
Ответ на: комментарий от th3m3

Ядро 4.14.10 ... LTS называется.

Откуда вы такие лезете?

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

У меня стандартное ядро. Тем не менее, обновление всё поломало.

th3m3 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Update: в 4.14.11 работает.

т.е. nvidia нормально работает с данным ядром ?

Kenny3k ()
Ответ на: Update: в 4.14.11 работает. от Kenny3k

т.е. nvidia нормально работает с данным ядром ?

Да:

$ lspci | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)

$ lsmod | grep nvidia
nvidia_drm             53248  2
nvidia_modeset        897024  5 nvidia_drm
nvidia              14008320  400 nvidia_modeset
drm_kms_helper        192512  1 nvidia_drm
drm                   434176  5 nvidia_drm,drm_kms_helper

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от Deleted

Опусти глаза чуть-чуть ниже:

LINUX=on: Linux compatibility support

Это для линуксятора, кяп. Можно собрать порт и без него.

commagray ★★★★★ ()
Ответ на: комментарий от Deleted

Там только библиотеки CUDA для Linux ставятся. Без них всё работает и так.

iZEN ★★★★★ ()

вообще видит карту вроде, а вот проприетарный драйвер не работает.
я на нуво перешел из-за этого на слаке

xmikex ★★★ ()
Ответ на: комментарий от steemandlinux

Как там Radeon RX Vega работает?

Только в FreeBSD 12-CURRENT.

«xf86-video-amdgpu-1.3.0_1 not supported on 11.x or older, no kernel support.»

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

То есть та же GTX 1060 заведется под фряхой без проблем, так? И если собрать вручную, то линуксулятор и не потребуется совсем?

Любопытно, надо потыкать.

Deleted ()

Собственно, данный топик прекрасно демонстрирует что из себя представляет Ubuntu LTS.

Polugnom ★★★★★ ()
Ответ на: комментарий от xmikex

на нуво перешел из-за этого на слаке

Отчего попросту не пересобрать ядро с патчем?

bormant ★★★★★ ()
Ответ на: комментарий от iZEN

Там нет веги в списке. Карточка не такая простая и стандартный порт с линупсячего ядра она не воспримет. В общем 4.14.10 тоже не поддерживается xD

steemandlinux ★★★★★ ()
Последнее исправление: steemandlinux (всего исправлений: 1)
Ответ на: комментарий от steemandlinux

Со временем будет и Linux 4.15, и FreeBSD 12-RELEASE, и xf86-video-amdgpu-1.4.0, который будет поддерживать последнее видеоядро AMD с Vulcan 1.0 API. Пока же и на линуксе оно нестабильно и нуждается в доработке. Так что для линуксоидов лучше ставить AMDGPU-Pro, оно по крайней мере работает на старых ядрах.

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

Так что для линуксоидов лучше ставить AMDGPU-Pro, оно по крайней мере работает на старых ядрах.

Нет, там только amdgpu-dkms нужен, остальное мусор.

steemandlinux ★★★★★ ()
Ответ на: комментарий от bormant

Да мне не особо нужна Nvidia вместо Нуво, на Нуво хоть с kms проблем нет

xmikex ★★★ ()

у всех потухло - успокойся, на sid еще 6-го числа прилетело ядро 4.14.12 и вся проприетарщина рухнула, да и хер с ним - пересел на иксы, у меня самая тухлая из современных 210-я в шестеренках 300 фпс шпарит - куда больше...

amd_amd ★★★ ()
Ответ на: комментарий от xmikex

На блобе на более-менее новых картах есть норм разрешения в vesafb.

anonymous ()
Ответ на: комментарий от amd_amd

Моя затычка в шестерёнках шпарит 24000 fps (тысяч, да).

anonymous ()
Ответ на: комментарий от I-Love-Microsoft

это и есть LTS, но версия ядра странная для 16.04

targitaj ★★★★★ ()
Ответ на: комментарий от anonymous

чего 210-я 24000? сейчас еще попробую только drirc подправлю...

amd_amd ★★★ ()
Ответ на: комментарий от amd_amd

Нет, но на блобе и на ней было бы больше, нуво бесполезно гальванизировать.

anonymous ()
Ответ на: комментарий от anonymous

у меня на 210-ой в голых иксах потолок такой

3519 frames in 5.0 seconds = 703.772 FPS
3530 frames in 5.0 seconds = 705.966 FPS
3532 frames in 5.0 seconds = 706.364 FPS
3529 frames in 5.0 seconds = 705.709 FPS
3529 frames in 5.0 seconds = 705.599 FPS
3529 frames in 5.0 seconds = 705.657 FPS
3529 frames in 5.0 seconds = 705.743 FPS
3528 frames in 5.0 seconds = 705.538 FPS
сильнее не раскочегарить - да куда больше, 705 кадров это сумашествие - глаз больлше 24-х не видит

amd_amd ★★★ ()
Ответ на: комментарий от amd_amd

Glxgears слишком простой, на более сложных сценах фпс пропорционально проседает. А так глаз прекрасно отличает 24 и 60 фпс, как минимум.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.