LINUX.ORG.RU

Ubuntu 17.10 медленное переключение раскладки клавиатуры

 ,


1

1

После переключения раскладки где-то полсекунды не работает ввод с клавиатуры. Переключение клавишами Super+Space (смена комбинации клавиш для переключения раскладки в 17.10 не работает). Вроде бы при переключении появляется на короткое время окно, которое не сразу исчезает и «съедает» нажатия клавиш. Есть как это починить? (кроме смены дистрибутива или даунгрейда до 17.04)

Ооочень информативно.
У ми, на пример, в xfce громкость с затупами кнопками регулируется. А про яркость я вообще молчу.
Ты б хоть de сказал.

hbars ★★★★★ ()

Настрой переключение раскладки в gnome-tweak-tool (как - воспользуйся поиском по сайту), на всякий пожарный, отключи super+space в настройках.

Cообщи, какой сеанс используется (wayland/xorg).

anonymous ()
Ответ на: комментарий от anonymous

изменение клавиш переключения раскладки не работает в 17.10 :-(

использую xorg, в wayland не работают некоторые нужные мне приложения

pjotar ()
Ответ на: комментарий от pjotar

Ты точно в gnome-tweak-tool делал? Какие сочетания пробовал ставить? Это отдельное приложение, его нужно устанавливать отдельно, в стандартной убунте нет.

anonymous ()
Ответ на: комментарий от pjotar

а драйвер карты у тебя какой?
может свободный или блоб тупят? в плане бреда предлагаю.

Deleted ()
Ответ на: комментарий от pjotar

Воот, получилось сменить так:

settings set org.gnome.desktop.wm.keybindings switch-input-source "['<Shift>Alt_L']"
Работает правда только в порядке нажатий shift потом alt.

Переключение всёравно происходит долго

pjotar ()

Вот тут ругаются на это окно, но тоже не могут выключить :-(

В документации оно называется Input Source chooser

Может быть можно поставить отдельные горячии клавиши на русскую и английскую раскладку?

pjotar ()
Ответ на: комментарий от pjotar

попробуй

gsettings set org.gnome.desktop.input-sources xkb-options "['grp:caps_toggle']"
, этот параметр устанавливает gnome-tweak-tool (смена языка на капс лок, без появления всплывающего окна). По идее, если не заработает, может выдаст какую-нибудь инфу об ошибке.

Не представляю с чем это может быть связано. У меня тоже убунта 17.10, меняю по супер+пробел, когда жму их одновременно переключение происходит моментально лдваыоаdfklsjdfsвалдоkldjfsвалдоао, без появления виджета.

anonymous ()

Сейчас проверил, и на иксах и на вэйланде все норм. Что-то не так с твоей убунтой (или оборудованием?). Каким образом получена 17.10 - обновлялся с 17.04? В таком случае проблема может быть из-за кривого переноса каких-то юнити-настроек в гном (или чего-то такого). Попробуй зарепортить баг, маловероятно что починят, но может какую-то подсказку дадут.

anonymous ()
Ответ на: комментарий от anonymous

Вспомнил, попробуй установить пакет gnome-session и залогиниться в сессию gnome, а не ubuntu (емнип, потребуется перезагрузка после установки, успешно перезагрузить gdm для обновления списка доступных сессий мне не удавалось). Возможно, убунтодевелоперы накрутили своих патчей, не понимая как все устроено, и поломали переключалку.

anonymous ()
Ответ на: комментарий от anonymous

попробуй

gsettings set org.gnome.desktop.input-sources xkb-options "['grp:caps_toggle']"
, этот параметр устанавливает gnome-tweak-tool (смена языка на капс лок, без появления всплывающего окна). По идее, если не заработает, может выдаст какую-нибудь инфу об ошибке.

Это офигенно! Я какраз хотел сменить на клавишу casp! Окно не появляется, проблема решена, спасибо!

pjotar ()
Ответ на: комментарий от anonymous

попробуй установить пакет gnome-session и залогиниться в сессию gnome

а вот это похоже отдельная песня, у меня после сна или блокировки появляется какое-то другое окно разблокировки, в которое не подходит пароль :-) Терплю пока, не блокирую и не усыпляю комп на ночь

pjotar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.