LINUX.ORG.RU

Версии Python в Linux Mint

 , ,


0

1

Добрый день! Использую Linux Mint 17.3 Rosa. У меня стоит Python3 версии 3.4.3. Как узнать какие версии этого пакета доступны в репозитории более новых версий Linux Mint? Смотрел на Distrowatch, но для Минт там нашел только версии второго Python. Нужен Python версии 3.5 или выше и возможность устанавливать пакеты с помощью pip именно для этой версии Python. Пробовал устанавливать Python версии 3.5, пользуясь инструкцией https://stackoverflow.com/questions/34372731/installing-python-3-5-on-linux-m..., но pip работает с версией 3.4.3. У меня есть пакеты python-pip и python3-pip, каждый из которых работет с соответствующей версией Python. Как сделать чтобы можно было устанавливать через pip пакеты для Python версии 3.5?


Используй virtualenv для pip:

mkdir venv
virtualenv --python=/usr/bin/python3.5 venv
cd venv/
source bin/activate

После source у тебя будen pip и python привязаны к python3.5, а модули питона ты будешь ставить в созданное виртуальное окружение под выбранный в команде virtualenv питон.

Norgat ★★★★★ ()