LINUX.ORG.RU

opensuse + bumblebee + nvidia

 , ,


0

1

Доброго времени суток. Установил 42.3 Leap и второй день пытаюсь заставить работать видюху - bumblebee установился нормально, карта включается-отключается, не могу поставить драйвера nvidia. Ставил с репозитория проприетарных дров G04 (карта 620М), noveau заблеклистил, mkinitrd сделал.

Выхлоп optirun:

catsoup@linux-bsi4:~> optirun --debug glxspheres
[18008.763127] [DEBUG]optirun version 3.2.1 starting...
[18008.763163] [DEBUG]Active configuration:
[18008.763168] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[18008.763173] [DEBUG] X display: :8
[18008.763180] [DEBUG] LD_LIBRARY_PATH: /usr/lib64/nvidia:/usr/lib/nvidia
[18008.763199] [DEBUG] Socket path: /var/run/bumblebee.socket
[18008.763207] [DEBUG] Accel/display bridge: auto
[18008.763216] [DEBUG] VGL Compression: proxy
[18008.763225] [DEBUG] VGLrun extra options: 
[18008.763233] [DEBUG] Primus LD Path: /usr/lib64/primus:/usr/lib/primus
[18008.763272] [DEBUG]Using auto-detected bridge virtualgl
[18008.831837] [INFO]Response: No - error: Could not load GPU driver

[18008.831871] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[18008.831886] [DEBUG]Socket closed.
[18008.831907] [ERROR]Aborting because fallback start is disabled.
[18008.831922] [DEBUG]Killing all remaining processes.
catsoup@linux-bsi4:~> 
Прошелся по патчам в bumblebee.conf - в LD_LIBRARY_PATH: /usr/lib64/nvidia, в lib64 вообще нет nvidia, отсюда вывод - или дрова не там (версия 385.какиетоцифры, с репы nvidia) или их нет совсем, хотя в /usr/lib/nvidia находится 4 скрипта (либы где?) мужики, куда ковырять, чтобы не усугубить?

Открой YAST, найди пакет, выведи список файлов.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.