LINUX.ORG.RU

GTK 3.0 scrollbar width, а лучше - сделать 2.0 look-and-feel

 ,


1

2

Всем привет.

IceWM, без Гнома3, Debian 9 Stretch (без systemd).

Не во всех программах, но бывают тонкие скроллбары, причём исчезающие, когда уводишь мышь из их окна. Бесит.

Пробовал писать:

.scrollbar {
-GtkRange-slider-width: 30;
}
в файлы /usr/share/themes/Default/gtk-3.0/gtk-widgets.css и в /etc/gtk-3.0/gtk-widgets.css - не помогает.

В идеале - найти нормальную тему, имитирующую GTK 2.0. Но, насколько я понял, таких нет? (типа РэдХэт специально ломает спецификации, чтобы ломались темы - чтобы люди сидели на их дефолте, и не портили внешний вид их торговых марок)

(ещё злила «фича» в GTK 3.0 с длинным нажатием на скроллбар - когда он начинает очень медленно двигаться - но для этого я нашёл конфиг)

Как увеличить ширину скроллбаров? Как зафиксировать их внешний вид - для всех приложений? (и вообще - как бороться со всем этим новомодием от РэдХэта? - т.е. имитировать GTK 2.0?)


В идеале - найти нормальную тему, имитирующую GTK 2.0. Но, насколько я понял, таких нет?

Старая добрая TraditionalOk из mate-themes. Проблема в том, что в Gtk3 появились новые виджеты, который выглядят только более менее удачно.

gag ★★★★★ ()
Ответ на: комментарий от gag

Спасибо.

Только вот не пойму как теперь задать эту тему. Пробовал переименовать директорию (в /usr/share/themes) в Default - не работает. И с переменной окружения GTK_THEME=Default тоже нет.. GnomeTweakTool пожалуйста не предлагать.

bass Тоже спасибо. Тоже не понял, куда воткнуть эти 2 строчки?

Переменная окружения не действует. Да, искал, видел - у других - действует, но у меня почему-то нет.. :(

(Правильный путь конечно - выкидывать из своей жизни такой софт, если он пишется с РэдХэт'овской дрянью.. Но ведь Firefox тоже перешёл на эти дебильные скроллбары.. А Хром ещё хуже..)

the1 ()
Ответ на: комментарий от bodqhrohro_promo

xsettingsd

Спасибо! Заработало. Firefox теперь почти в радость (только бы ещё через-раз открывающий табы middle-button починили бы..)

Всё-таки, нельзя ли просто указать GTK3, что я хочу директорию TraditionalOk (скопированную откуда-то, 815КБ) использовать как конфиг? :) (запускать демон, в конфиг-файле которого указать тему, чтобы он по хз-какому протоколу сообщал её программам - ну бред же.. и 50МБ (какие-то другие пакеты ещё встали) ради нормальных скролбаров - тоже немного изврат..)

Куда прописана?

На всякий случай: тут мы про отключение оверлея. Вписал и в .bashrc, с полным перелогином, и просто присвоил значение (в одной командной строке) перед названием программы (запускаю terminator). Причём однажды - работало! Но я не понял что я такого сделал волшебного. Не работает вобщем.

Вы лучше сами сразу пишите куда что надо вставить.

the1 ()
Ответ на: комментарий от the1

ну бред же

Гноморастия типичная.

50МБ (какие-то другие пакеты ещё встали)

Чаго?

Depends: libc6 (>= 2.15), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2), libx11-6

сразу пишите куда что надо вставить

Да оба способа правильные. Первый — если с export, конечно. Так-то второй УМВР.

bodqhrohro_promo ()
Ответ на: комментарий от bodqhrohro_promo

Да, действует переменная окружения (gnumeric, File -> Open).

Видимо просто terminator (Prefs -> Key bindings) её игнорит..

Чаго?

Я про mate-themes.

-------------

А вот в gnumeric эти супер скроллбары не двигаются :(

the1 ()
Ответ на: комментарий от bodqhrohro_promo

Покажи /var/log/apt/history.log

Commandline: apt-get install --no-install-recommends mate-themes

Install: gtk2-engines:amd64 (1:2.20.2-3, automatic), gtk2-engines-murrine:amd64 (0.98.1.1-6, automatic), mate-icon-theme:amd64 (1.16.2-1, automatic), gtk2-engines-pixbuf:amd64 (2.24.31-2, automatic), mate-themes:amd64 (3.22.11-1)

Ты лучше сразу говори как надо правильно эту тему ставить. Я старпёр, отбрыкиваюсь как могу от этого всего РэдХэт'ного.. вот и не в курсе.

the1 ()