LINUX.ORG.RU

lubuntu-desktop как поставить

 


0

1

sudo apt install lubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
lubuntu-desktop : Depends: pidgin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

счас стоит унылый openbox
update upgrade autoremove autoclean не помогает
при попытке поставить pidgin вылазят другие ошибки

sudo apt install pidgin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pidgin : Depends: libpurple0 (>= 1:2.10.12) but it is not going to be installed
Depends: perlapi-5.22.1
Recommends: gstreamer1.0-alsa but it is not going to be installed or
gstreamer1.0-pulseaudio but it is not going to be installed
Recommends: gstreamer1.0-libav but it is not going to be installed
Recommends: pidgin-libnotify but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

добавлю что система lubuntu 16 но при старте запускается openbox

kommersant ★★ ()
Ответ на: комментарий от anonymous

sudo apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done

kommersant ★★ ()

Для начала:

$ sudo apt update
$ sudo sh -c "echo 'APT::Install-Recommends "false";' >> /etc/apt/apt.conf.d/75recommend"
$ sudo apt install pidgin
$ sudo rm /etc/apt/apt.conf.d/75recommend
$ sudo apt install lubuntu-desktop
Обновление списка пакетов, отключение установки рекомендуемых (для Pidgin), включение их назад, установка lubuntu-desktop.

SEInterix ()
Ответ на: комментарий от Karthago

# deb cdrom:[Lubuntu 16.04.2 LTS _Xenial Xerus_ - Release amd64 (20170215)]/ xenial main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ua.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ua.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial universe
deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ua.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://ua.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://ua.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb http://ftp.us.debian.org/debian sid main

kommersant ★★ ()
Ответ на: комментарий от SEInterix

sudo apt install pidgin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pidgin : Depends: libpurple0 (>= 1:2.10.12) but it is not going to be installed
Depends: perlapi-5.22.1
Recommends: gstreamer1.0-alsa but it is not going to be installed or
gstreamer1.0-pulseaudio but it is not going to be installed
Recommends: gstreamer1.0-libav but it is not going to be installed
Recommends: pidgin-libnotify but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

kommersant ★★ ()
Ответ на: комментарий от SEInterix

Вдогонку: если останется только сообщение о libpurple0, то поставь пакет libpurple0:

% wget https://security.ubuntu.com/ubuntu/pool/universe/p/pidgin/libpurple0_2.10.12-0ubuntu5.2_amd64.deb
% sudo dpkg -i libpurple0_2.10.12-0ubuntu5.2_amd64.deb
После установки делаешь % sudo apt -f install (на случай, если dpkg выдаст ошибку при установке, он пакет установит, просто зависимости подцепить нужно будет). Если все пройдет гладко, можно ставить Pidgin по % sudo apt install pidgin).

SEInterix ()
Ответ на: комментарий от SEInterix


sudo dpkg -i libpurple0_2.10.12-0ubuntu5.2_amd64.deb
(Reading database ... 190502 files and directories currently installed.)
Preparing to unpack libpurple0_2.10.12-0ubuntu5.2_amd64.deb ...
Unpacking libpurple0 (1:2.10.12-0ubuntu5.2) over (1:2.10.12-0ubuntu5.2) ...
dpkg: dependency problems prevent configuration of libpurple0:
libpurple0 depends on libperl5.22 (>= 5.22.1); however:
Package libperl5.22:amd64 is not installed.
libpurple0 depends on perlapi-5.22.1; however:
Package perlapi-5.22.1 is not installed.

dpkg: error processing package libpurple0 (--install):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.24-12) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
libpurple0

kommersant ★★ ()
Ответ на: комментарий от kommersant

После установки делаешь % sudo apt -f install (на случай, если dpkg выдаст ошибку при установке, он пакет установит, просто зависимости подцепить нужно будет).

SEInterix ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.