LINUX.ORG.RU

Вертикальная синхронизация в awesome wm

 , , ,


0

1

Проблема следующая: после установки awesome я заметил, что при скроллинге текста или просмотре видео - при любом динамическом изменении содержимого экрана, появляется линия, которая мучает мое сердце и глазки. Вот как тут, только выше. Пример картинки!

Внимание! Я сначала грешил на драйвера жифорса, но после установки на другую машину убунты и осома 3.5 была та же самая проблема! Конфигурация первой машины жифорс 750ти дебиан тестинг:

#uname -a
Linux debian 4.9.0-1-amd64 #1 SMP Debian 4.9.6-3 (2017-01-28) x86_64 GNU/Linux
#
#
#awesome --version
awesome v4.0 (Harder, Better, Faster, Stronger)
 • Compiled against Lua 5.1.5 (running with Lua 5.1)
 • D-Bus support: ✔
 • execinfo support: ✔
 • RandR 1.5 support: ✔
 • LGI version: 0.9.1

на второй машине (ноуте): hd graphics 3000

ubuntu 16.10

awesome 3.5

P.S. Не могу сказать с уверенностью, но на второй машине, совсем недавно, стояла ubuntu 16.04 и awesome, собранный из сорцов месяца два назад. И такой проблемы я там не помню! А значит ее не было. Вот, надеюсь, это поможет вам сделать нужные выводы и помочь мне =)


Это называется tearing. Посмотри в настройках своих драйверов, там может быть настройка для борьбы с этой бедой. Некоторые еще советуют использовать композитный менеджер, например compton. И иногда это даже помогает.

Посмотрю, может кто-нибудь что-то новенькое посоветует, ибо у меня приведенные выше способы эту проблему не решают.

feofan ★★★★★ ()

Гугли ForceFullCompositionPipeline, обычно помогает на nvidia.

schlae ()

грешил на драйвера жифорса

Попробуй AMD с открытыми драйверами. Если всё так же то баг в твоей версии awesome.

anonymous ()
Ответ на: комментарий от anonymous

Так вот он какой - троллинг анонимусов на лоре...

Voaz ()
Ответ на: комментарий от feofan

Попробовал compton, но не помогло. Что делал: Добавил в .xinitrc:

compton --vsync opengl-swc --backend glx -b
Voaz ()
Ответ на: комментарий от Voaz

попробуй руками в консоли с разными бэкэндами и в разных режимах потыкать. Может какой-то и сгодится. У меня не nvidia.

Только сначала прибей прежний инстанс:

killall -9 compton
feofan ★★★★★ ()
Последнее исправление: feofan (всего исправлений: 1)

УМВР

intel hd3000

awesome -v
awesome v3.5.9 (Mighty Ravendark)
 • Build: Aug 20 2016 11:35:34 for x86_64 by gcc version 4.9.3 (@x220)
 • Compiled against Lua 5.1.5 (running with Lua 5.1)
 • D-Bus support: ✔
На пека с жифорс 760 вроде та же версия.

это поможет вам сделать нужные выводы

Сделай выводы, может попробовать откатить версию назад.

stage3 ★★ ()
Ответ на: комментарий от Voaz

opengl-swc

Он работает только у пары человек на этом шарике.

r3lgar ★★★★★ ()

жифорс 750ти

установлен nvidia-libgl?

Попробовал compton, но не помогло

А если так?

compton --vsync opengl --xrender-sync --xrender-sync-fence --backend glx -b
Только выключи вертикальную синхрониацию в nvidia-settings

flappyright ()
Ответ на: комментарий от aegi

Я имею в виду, что он полноценно работает, а не просто жрёт проц. Если у тебя действительно работает, то это хорошо.

r3lgar ★★★★★ ()
Ответ на: комментарий от schlae

SOLVED!

Оно работает! (с видеокартой Nvidia 750ti) Сначала гуглилось что-то непонятное, но потом нашел.

Что сделал: «NVIDIA X Server Settings» -> «X Server Display Configuration» -> «Advanced» -> и галочку напротив «Force Full Composition Pipeline»

зы: NVIDIA Driver Version: 375.26

Voaz ()
Ответ на: SOLVED! от Voaz

А чтобы не сбрасывалось при переключении видео режимов, в секцию Device конфига xorg.conf достаточно добавить

    Option  	   "ForceFullCompositionPipeline" "true"

schlae ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.