LINUX.ORG.RU

Замена xfce4-mixer для debian?

 , ,


1

2

Из debian ustable выпилили xfce4-mixer
https://packages.debian.org/search?keywords=xfce4-mixer

Вопрос чем заменить xfce4-mixer?
Требования:
1) виджет в панели
2) без qt
3) без pulseaudio
4) deb пакет

Смотрел на xfce4-pulseaudio-plugin (pulseaudio), qasmixer (qt), gnome-alsamixer(нет виджета).

ну, xfce4-mixer (4.11.0-1) без проблем работает в xfce 4.12
можешь сам собрать, а можешь скачать с snapshot.debian.org

yrii2121 ()

В testing такое часто бывает. Причина в сути веток. В experimental ад, содомия и bleeding edge, на рабочих системах такое юзают только отпетые экстремалы и убунтята. В sid кидают заведомо сырое и потенциально глючное, если оно таки глючит — всем пофиг, просто как можно скорее запатчат и обновят, как в Arch Linux. В stable принимают только хорошо оттестированые версии; если после релиза в них находятся малозначительные глюки — эти глюки документируются (багофича), если это уязвимости — патчатся, если это серьёзные проблемы, даже исправленные в последующих версиях, но не связанные с безопасностью — пакет выкидывается из репозитория, но случается такое редко. В testing же поступают версии без явных глюков, но не застрахованные от них — в основном либо beta-, либо релизные версии (стабильная по мнению разработчиков версия далеко не всегда является достаточно стабильной по меркам Debian). Если находятся серьёзные глюки, пакет выкидывается из testing, пока в sid не появится версия без них. Также причиной выкидывания может быть несовместимость версий — ведь в отличие от stable, где всё консервируется таким образом, чтобы быть как можно более совместимым, в testing кидают просто свежие пакеты, которым нужны разные версии библиотек, и может такое случиться, что они несовместимы. Отследить такое трудно, иногда не находят и случаются проблемы при обновлениях (APT в зависимости от настроек может либо отказаться обновлять кучу пакетов ради одного установленного, либо потребовать вынести установленный, для которого нет обновлений), иногда находят и, опять-таки, выносят, пока мейнтейнеры не подготовят версию с неконфликтными зависимостями.

Решение простое — либо просто не обновлять выкинутый пакет и пострадавшие из-за него, пока зависимости не утрясутся и его не вернут, либо поставить пакет из другого источника — например, из того же sid или репозиториев Ubuntu. Либо просто скачать и установить через `dpkg -i`, либо добавить в `sources.list` репозиторий sid и аккуратно настроить Pin-Priority, чтобы оттуда устанавливались только нужные пакеты, а не всё подряд. Идти на поводу у администраторов репозиториев, маркетов и прочих помоек софта не нужно.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.