LINUX.ORG.RU

Монитор после спячки включается только с помощью alt + ctrl + fN

 , , , ,


0

4

С некоторых пор после длительного отсутствия за компьютером я могу заставить очнуться монитор только после нажатия комбинации alt + ctrl + fN, хотя раньше вполне хватало движения мышью или нажатия любой кнопки на клавиатуре.

И совершенно не могу сообразить, в какую сторону копать.

Такая же фигня на кухонном мини-ПК, подключённом к монитору. Удваиваю вопрос.

// P.S: Bay Trail (Atom Z3735F), Fedora 24.

carasin ★★★★★ ()
Ответ на: комментарий от cheerfulboy

Я забил. Показал жене волшебную комбинацию клавиш переключения по виртуальным терминалам и не парюсь.

carasin ★★★★★ ()

Ноутбук или PC ?

Похожая ситуация (ноут), яркость монитора устанавливается в 0 и не возвращается в исходное значенеи - просто назначил хоткей на регулировку яркости монитора и хоткеем поднимаю яркость выше 0.

zaz ★★★★ ()

У меня тоже только так зажигается.

Deleted ()

На ноутбуке аналогичная проблемма. Arch, i3wm, startx. Монитор показывает изображение, но не текущее, а «из прошлого». В tty та же фигня. Подозреваю драйвер штеуда. TC, проверь tty и другое железо (не штеуд gpu). Экран именно чёрный или «замороженный»?

robus ★★★★ ()
Последнее исправление: robus (всего исправлений: 1)
Ответ на: комментарий от cheerfulboy

Если в tty компьютер будет долго не использоваться, то будет ли воспроизводиться проблемма?

robus ★★★★ ()

Посоны, моя проблема была в пустой директории /sys/class/backlight.

Проблема решилась добавлением acpi_backlight=video к параметрам ядра.

Расходимся.

cheerfulboy ()
Ответ на: комментарий от cheerfulboy

Хорошо быть тобой, у меня погасший монитор лечится только перезагрузкой.

anonymous ()

Не, беру свои слова назад. Наличие acpi_video0 в /sys/class/backlight не повлияло на ситуацию.

А у вас все в порядке с устройствами?

cheerfulboy ()

И так, уже 2 дня полет нормальный. Вот список мероприятий, которые я произвел:

Сначала я добавил к загрузке ядра acpi_backlight=video, чтобы появилось устройство /sys/class/backlight/acpi_video0. Так же по реокомендациям из сети у меня стоит acpi_osi=Linux. Не знаю, играет ли это какую-нибудь роль.

Так как у меня intel, я сменил акселерацию с uxa на sna. До этого использовалась uxa из-за необновляющегося терминала на sna. Но это вылечилось использованием второй версии DRI. Конфиг:

Section "Device"
    Identifier  "Device0"
    Driver      "intel"

    Option      "AccelMethod"  "sna"
    Option      "DRI"          "2"

    # https://bugs.archlinux.org/task/27677
    Option      "Backlight"    "intel_backlight"

    # Избавляет от тиринга. Потестировать можно тут:
    # http://www.youtube.com/watch?v=22ftfoCSPQI
    Option      "TearFree"     "true"
EndSection

Возможно, это довольно избыточно, но если у кого-то получится, как у меня — отпишитесь.

cheerfulboy ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.