LINUX.ORG.RU

pulse странное поведение

 , ,


0

1

Система debian jessie(stable). В общем прошла загрузка, запустились все приложения из автозапуска. Звук в броузере и в скайпе есть. Открываю deadbeef - звука нет. Смотрю логи:

May 11 11:51:52 localhost rtkit-daemon[8877]: Successfully made thread 10033 of process 10033 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 5 threads of 2 processes of 1 users.
May 11 11:51:52 localhost pulseaudio[10033]: [pulseaudio] module.c: module-detect is deprecated: Please use module-udev-detect instead of module-detect!
May 11 11:51:52 localhost pulseaudio[10033]: [pulseaudio] sink.c: Default and alternate sample rates are the same.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 5 threads of 2 processes of 1 users.
May 11 11:51:52 localhost rtkit-daemon[8877]: Successfully made thread 10040 of process 10033 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 6 threads of 2 processes of 1 users.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 6 threads of 2 processes of 1 users.
May 11 11:51:52 localhost rtkit-daemon[8877]: Successfully made thread 10041 of process 10033 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 7 threads of 2 processes of 1 users.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 7 threads of 2 processes of 1 users.
May 11 11:51:52 localhost rtkit-daemon[8877]: Successfully made thread 10046 of process 10033 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
May 11 11:51:52 localhost rtkit-daemon[8877]: Supervising 8 threads of 2 processes of 1 users.
May 11 11:51:52 localhost pulseaudio[10033]: [pulseaudio] main.c: D-Bus name org.PulseAudio1 already taken.
May 11 11:51:52 localhost pulseaudio[10028]: [pulseaudio] main.c: Daemon startup failed.

Делаю pulseaudio -k, говорит, что демон не запущен, но в процессах он висит. Делаю killall -9 pulseaudio и потом pulseaudio --start или pulseaudio -D и везде звук есть. Как это чинить ? Банально напрягает постоянно перезапускать пульсу вручную

★★★★

В ~/.config/pulse/client.conf добавляешь autospawn = no и убиваешь пульсу. Всё. В заивсимости от DE, может понадобиться доустановка регулятора громкости для ALSA.

ZenitharChampion ★★★★★ ()

pulse
странное

Когда-то было иначе?

kas501 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.