LINUX.ORG.RU

Няшность gtk2 заключается только в отсутствии твоей любимой темы под gtk3?

Прекращай некрофилить и переходи. Либо укатывайся с cutting-edge арча на ретроградную генту или слаку.

entefeed ☆☆☆ ()

у меня тоже обновился, но вообще ничего внешне не изменилось. Единственное спросил, улучшить поддержку подсказок в адресной строке. А что собственно изменилось, можно скрин?

kiotoze ★★★★ ()

Как его убрать и вернуть мой няшный GTK2?

Если хочется сидеть на старье, тогда сиди на 42.

th3m3 ★★★★★ ()
Ответ на: комментарий от entefeed

Няшность gtk2 заключается только в отсутствии твоей любимой темы под gtk3?

Эта тема очень кривая, не хочу ещё кучу времени проводить, плавая в говне и фикся её. Тем более весь софт в системе на GTK2.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Если твоей темы еще нет под gtk3 то она не только кривая, но и никому не нужное говно, а единственный ее любитель - ты - криворукий рак. Нет поводов не перейти с этой параши.

весь софт в системе на GTK2.

Может у тебя еще второй питон и sysvinit? Ну и зачем тебе арч? У вас идеологии не сходятся. Катись на генту, пенсионерам там самое место.

entefeed ☆☆☆ ()
Ответ на: комментарий от entefeed

Единственная нормальная тема для gtk, которую сделал dagaragga, потом допилил Dontes, а потом я в своей версии внёс изменения. А для gtk3 вообще нет нормальных тем, которые бы подходили под моё текущее оформление.

sudopacman ★★★★★ ()
Ответ на: комментарий от wakuwaku

Тупой нож не режет. Как там ваш sysvinit/openrc? udev уже переписали? Нет? Опять умер? Как жаль. Против чего вы там еще копротивляетесь? Ну, против прогресса это понятно, а если конкретно?

entefeed ☆☆☆ ()
Ответ на: комментарий от entefeed

Самое интересное, что eudev всё ещё жив и даже пользуется спросом. И при чём тут systemd? Я против него ничего не имею. И он полностью поддерживается наравне с openrc.

wakuwaku ★★★★ ()

выбирай

  • даунгрейднуться и запретить обновление
  • пересобирать каждый раз при обновлении
  • перейти на форк
  • менять дистр
f1u77y ★★★ ()
Последнее исправление: f1u77y (всего исправлений: 2)
Ответ на: выбирай от f1u77y
  • сменить пол
  • ориентацию
  • религию
  • страну проживания

Что угодно, главное не менять всеми забытую и всратую гтк2-онли тему.

entefeed ☆☆☆ ()
Ответ на: комментарий от entefeed

хз, всратая она или нет, но переводить на gtk3, а затем мэйнтейнить тему — тот ещё кактус в анусе, особенно при нынешнем состоянии тулкита. если ты альтруист с кучей свободного времени, то можно.

f1u77y ★★★ ()

Осуществлённый в бета-версии перевод сборок для платформы GNU/Linux на GTK3+ в очередной раз не вошёл в релиз.

Это во всех новостях наврали?

iu0v1 ()
Ответ на: комментарий от f1u77y

особенно при нынешнем состоянии тулкита.

Я потыкал программы на GTK+3, ИМХО он гораздо стабильнее того же Qt 5.

EXL ★★★★★ ()
Ответ на: комментарий от fornlr

А как вы отличаете то gtk2 или gtk3?

По всратому файлодиалогу.

Akamanah ★★★★★ ()
Ответ на: комментарий от Deleted

Как? В PKGBUILD можно было только убрать зависимость gtk3?

sudopacman ★★★★★ ()
Ответ на: выбирай от f1u77y

даунгрейднуться

Как? Я уже и этому был бы рад, но нигде пакета не нахожу.

пересобирать каждый раз при обновлении

Как мне его пересобрать, чтобы был gtk2 ? В PKGBUILD на это намёков нет.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

но нигде пакета не нахожу.

Вроде нашёл, в кеше пакмана. Отлично.

Как мне его пересобрать, чтобы был gtk2 ?

Покопался на сайте арчика, нашёл там пакет firefox, в source files есть файл mozconfig, в котором строчка

ac_add_options --enable-default-toolkit=cairo-gtk3
видимо и задаёт версию gtk, с которой надо собирать. Но вот только этот файл mozconfig при сборке через yaourt -Sb редактировать не предлагают.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Как? Я уже и этому был бы рад, но нигде пакета не нахожу.

Самый простой способ aur>downgrade

Для автоматического редактирования для пересборки есть customizepkg и форки.

Vigi ()
Ответ на: комментарий от sudopacman

редактировать не предлагают.

сделай diff mozconfig'a, затем каждый раз при редактировании pkgbuild просто указывай, что его нужно применять. это вроде как легче, чем каждый раз искать строчку в мозконфиге.

f1u77y ★★★ ()
Ответ на: комментарий от entefeed

не все школьники — альтруисты. я вот, например, альтруистом не являюсь.

а свободного времени для арча и правда нужно дофигища

f1u77y ★★★ ()
Последнее исправление: f1u77y (всего исправлений: 1)
Ответ на: комментарий от f1u77y

нужно дофигища

Это для настройки. Я вот уже месяца 3-4 особо ничего не настраиваю, у меня уже всё настроено и работает.

sudopacman ★★★★★ ()
Последнее исправление: sudopacman (всего исправлений: 2)
Ответ на: комментарий от Hertz

Там тоже запилили поддержку gtk3, у меня на генте так собран.

anonymous ()
Ответ на: комментарий от entefeed

Тупой нож не режет. Как там ваш sysvinit/openrc? udev уже переписали? Нет? Опять умер? Как жаль. Против чего вы там еще копротивляетесь? Ну, против прогресса это понятно, а если конкретно?

entefeed ★ (12/16/2015 23:48:36) systemd'нутый

Молодец, сумел скатить топик про браузер в поттерингосрач на ровном месте, возьми с полки пирожок.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от sudopacman

Всё собралось отлично, теперь у меня FF 43 на GTK2. Тему отмечаю как решённую.

Потом это уберут, так что не рассчитывай особо на пересборку. Тебе остаётся только фриз последней gtk2-версии, либо palemoon, либо страшное - перейти на chrome-like браузер.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Bfgeshka

перейти на chrome-like браузер

Если изобретут такой же кастомизируемый, как FF и при этом без зондов, то однозначно перейду

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

спермо-твики
портировать спермо-твики на новую версию не хочет, хочет в доту

пытается убеждать себя и всех что новые версии не нужны
продолжает жрать спермо-твики и доту, вместо чтобы пользоваться настроенной из коробки убунтой

anonymous ()
Ответ на: комментарий от sudopacman

Нее, они могут быть только толстыми или тонкими (причём со всей заявляемой легковесностью движок остаётся тот же и память улетает вникуда). Кастомизаций же там не бывает, даже близко с FF не сравнить. Самое большое достижение это залить интерфейс чёрным цветом.

Про зонды не скажу, аудит кода не делал.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от kiotoze

Диалоги открытия файлов и печати другие теперь, покрасивее, а остальное - как было так и осталось, ибо внутренний интерфейс - свой, а уж мелкие штучки - ГэТэКэ

mystery ★★ ()
Ответ на: комментарий от mystery

спасибо что объяснили, а то даже бы не заметил что именно изменилось. Странно, что из-за этого столько шума.

kiotoze ★★★★ ()

Adobe Flash это по сути единственное, что держит Firefox на gtk2. И на иксах.

i-rinat ★★★★★ ()

Вчера уже под утро хотел пересобрать себе, но то ли слишком пьян был, то ли у них на фтп снова ссылки видоизменились. В итоге пока так

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = firefox
#IgnoreGroup =

Если будешь пересобирать с гтк2, скинь, пожалуйста, пкгбилд в личку.

jori ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.