LINUX.ORG.RU

Gentoo + fglrx

 , , ,


0

1

Каждый раз при обновлении x11-drivers/ati-drivers обновляется файл /etc/X11/xorg.conf.d/20opengl.conf, в котором появляется строка ModulePath "/usr/lib32/opengl/ati/". X-сервер туда заглядывает и, не найдя ничего, что бы его устраивало, падает. Приходится загружаться в single-user и удалять строку, после чего всё работает (не проверял, правда, 32-битные приложения с 3D-ускорением). Кеды, по крайней мере, грузятся, а большего мне вроде и не надо. Тем не менее, каждый раз удалять эту строку мне не нравится. Посему привожу несколько информации, основываясь на которой господа лоровцы, возможно, мне помогут устранить эту проблему.

Файл /etc/X11/xorg.conf.d/20opengl.conf на данный момент:

Section «Files»
        ModulePath «/usr/lib64/opengl/ati»
        ModulePath «/usr/lib64/xorg/modules»
EndSection

x11-drivers/ati-drivers :

     Installed versions:  15.7-r1(1)^td(22:19:35 10.09.2015)(modules qt4 -debug -gdm-hack -pax_kernel -static-libs ABI_X86=«32 64» KERNEL=«linux»)

Если надо что-то ещё для дебага - говорите, приложу.


Ответ на: комментарий от smilessss

Костыль.

Похожих проблем не находил, значит, у остальных всё работает и иксы всё нужное находят. Хочу разобраться, почему не находят у меня.

alextk ()

создай /etc/X11/xorg.conf.d/30opengl.conf и запиши нужные строки, зорг будет смотреть после 20* и всё должно быть пучком.

kep ()
Ответ на: комментарий от Pinkbyte

О. Благодарю

От Вас всегда ответы самые ёмкие.

Ладно, тогда пока что сделаю костыль из первого варианта.

alextk ()
Ответ на: комментарий от grem

а хз, у меня mesa, так что блобопроблемы мимо меня прошли.

devl547 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.