LINUX.ORG.RU

Пустой список монтирования в Thunar

 , , ,


0

1

Thunar не видит ни одно из не примонтированных устройств, при «ручном» монтировании отображает. Dolphin при этом работает как надо.

Установлено:

xfce-base/thunar dbus exif libnotify pcre udisks
xfce-extra/thunar-volman libnotify
gnome-base/gvfs cdda http mtp systemd udev udisks

Distro: gentoo (Конфиг ядра)

WM: awesome

P.S. «Управление томами» тыкнуто. P.P.S.На ноуте на первый взгляд всё тоже самое (пакеты), но работает


WM тут не при чём. Попробуй pcmanfm, гугли на тему автоматического монтирования. Ну ещё в настройках тунара погляди.

sudopacman ★★★★★ ()
Ответ на: комментарий от tiandrey

Через KDM, и на пеке и на ноуте. Console Kit-а нет ни там, ни там.

smt ()
Ответ на: комментарий от sudopacman

Чего я только не насмотрелся пока гуглил на эту тему...

smt ()

gvfs-daemon / gvfs-fuse стоит?

ну exo должно и по зависимостям от thunar тащить

и ещё, был такой баг (пару лет назад точно) не монтировал thunar, скрипт такой делал:

cat /usr/local/bin/thunar-volman

#!/bin/sh
sleep 1
exec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1

amorpher ★★★★★ ()
Последнее исправление: amorpher (всего исправлений: 3)
Ответ на: комментарий от amorpher

Понятно, что ни при чём. Написал чтоб избежать вопросов о нём.

Чего я только не насмотрелся пока гуглил на эту тему...

smt ()

Нужно установить пакет xfce-extra/thunar-volman и в настройках задействовать автомонтирование.

kostik87 ★★★★★ ()
Ответ на: комментарий от amorpher

Такс, на пеке не запущен, на ноуте запущен. Как запускать? (gvfsd нет ни там, ни там, равно как и unit-а и в init.d тоже нету)

smt ()
Ответ на: комментарий от amorpher

Ну это относительно... + на ноуте ведь пашет

Исторически так сложилось: сначала были кеды, потом вкатил осом, а мир полностью пересобрать лень => кеды не выпилить, отсюда и 2 ФМ.

smt ()

Thunar не видит ни одно из не примонтированных устройств

У меня было подобное «невидение», то ли в долфине, то ли pacmanfm. Короче, я случайно как-то убрал из панели «places», какие-то пункты, и все. Диски перестали отображаться, что монтированные что не монтированные. Может быть дело в настроках файл-менеджера.

Csandriel ()

Гр*баный kdm... Заработало, расходимся (запустил через startx с «exec dbus-launch awesome» и всё заработало, я ничего не понимаю, правда...)

smt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.