LINUX.ORG.RU

KDM + Openbox + Thunar

 , , ,


0

1

Как получить монтирование флэшек в Thunar, который запускается в Ob, в который захожу через kdm?

Пробовал разные способы прописывать в ~/.config/openbox/autostart:

thunar --daemon &
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
   eval $(dbus-launch --sh-syntax --exit-with-session) &
fi
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
   eval $(dbus-launch --sh-syntax --exit-with-session)
fi
последний код точно работает, но во fluxbox'е (~/.fluxbox/startup). Что самое интересное, если через терминал запускаю Thunar так:
$ [ -z "$DBUS_SESSION_BUS_ADDRESS" ] && eval $(dbus-launch --sh-syntax --exit-with-session) ; thunar
Запустил Dolphin еще, в нем разделы и флэшки - все видно. Установлены:
Thunar-1.6.3-i486-2
thunar-archive-plugin-0.3.1-i486-1gv
thunar-volman-0.8.0-i486-1
gvfs-1.16.3-i486-2

dbus-1.6.12-i486-1
dbus-glib-0.100.2-i486-1
dbus-python-1.2.0-i486-1
libdbusmenu-qt-0.9.2-i486-2
libusb-1.0.9-i486-1
libusb-compat-0.1.4-i486-1

openbox-3.5.2-i486-1_SBo

★★★★★

В общем все таки добился, но все равно интересно может есть еще какие-нибудь способы?

Мое решение такое:

if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
   eval $(dbus-launch --sh-syntax --exit-with-session)
fi

thunar --daemon &

NK ★★★★★ ()

А что за дистрибутив? В Debian, например, dbus-launch можно запустить в /etc/X11/Xsession. Вообще, это по умолчанию так:

/etc/X11/Xsession.d/75dbus_dbus-launch:

# $Id:$
# In order to activate the session bus at X session launch
# simply place use-session-dbus into your /etc/X11/Xsession.options file
#

STARTDBUS=
DBUSLAUNCH=/usr/bin/dbus-launch

if has_option use-session-dbus; then
  if [ -x "$DBUSLAUNCH" ]; then
    STARTDBUS=yes
  fi
fi

if [ -n "$STARTDBUS" ]; then
  STARTUP="$DBUSLAUNCH --exit-with-session $STARTUP"
fi

А в /etc/X11/Xsession.option (последняя строчка):

# $Id: Xsession.options 189 2005-06-11 00:04:27Z branden $
#
# configuration options for /etc/X11/Xsession
# See Xsession.options(5) for an explanation of the available options.
allow-failsafe
allow-user-resources
allow-user-xsession
use-ssh-agent
use-session-dbus
Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

дистрибутив?

slackware-14.1

/etc/X11/Xsession.d/75dbus_dbus-launch
/etc/X11/Xsession.option

не, нет такого тут

# ls -a /etc/X11/
./   WindowMaker/   fs/   seyon/  xdm/    xkb/       xorg.conf-vesa  xorg.conf~
../  app-defaults/  mwm/  x3270/  xinit/  xorg.conf  xorg.conf.d/    xsm/
NK ★★★★★ ()
Ответ на: комментарий от NK

Ну, значит, Слака оставляет за пользователем запуск dbus. В принципе, можно вписать запуск и в ~/.profile, и в стартовые скрипты kdm, чтобы в начале сессии запустился dbus. Но и в скриптах оконного менеджера тоже сгодится. Если сессионный dbus никакими умолчательными скриптами не запускается в Слаке, то только самому. Можешь, в принципе, тоже похимичить с Xsession, чтобы запускалось вне зависимости от *dm и WM в самом начале. Можно, наверное, в ~/.xsession вписать. Только не знаю точно, запускает ли его KDM. Вроде должен.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 4)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.