LINUX.ORG.RU

Проблема с установкой драйвера nvidea

 , ,


0

2

Стоит дебиан 8, kde 4.14.2 Скачал драва с сайта nvidea .deb и .run Запускал из рута пишет:

ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at http://www.nvidia.com.

Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at http://www.nvidia.com.

Собственно текст из лога:

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Sat Jun 13 14:10:38 2015 installer version: 346.72

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line: ./nvidia-installer

Using: nvidia-installer ncurses user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '980' of a runnning X server. ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at http://www.nvidia.com

Пробывал останавливать иксы, переходил Ctrl+Akt+F1 etc/init.d/kdm stop, и после этого запускать, выдает тоже самое.

Ставь из репозитория. Не надо себе мозги так выкручивать. У тебя debian, не слака.

Deleted ()

драйвера nvidea

а что это такое хоть?

erfea ★★★★★ ()

Да научись уже читать

Читай внимательно, чтобы писать правильно и не задавать глупых вопросов.

nvidea

nvidia

драва

дрова

из рута

от рута

Пробывал

Пробовал

anonymous ()
telinit 3

затем запуской свой .run

anonymous ()
sudo systemctl disable kdm
sudo systemctl stop kdm
sudo killall Xorg
chmod +x *.run

Далее, ставишь свой *.run Но лучше конечно же, ставить драйвер из репы, как выше уже сказали.

w1nner ★★★★★ ()

Проблема новая Делал все по второму пункту Добавил репозитарии в sources.list Вот что там:

# 
# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 DVD Binary-1 20150606-14:19]/ jessie contrib main

#deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 DVD Binary-1 20150606-14:19]/ jessie contrib main

deb http://ftp.ru.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ unstable main contrib non-free
deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://ftp.ru.debian.org/debian/ jessie main
deb-src http://ftp.ru.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ jessie-updates main contrib
deb-src http://ftp.ru.debian.org/debian/ jessie-updates main contrib

Создал в каталоге /etc/apt/apt.conf.d/ 00release

APT::Default-Release "testing";

apt-get install module-assistant проходит

apt-get install -t sid nvidia-kernel-source выдает: >> тение списков пакетов… Готово E: Значение «sid» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках

Пробывал testing менять на Jessi, тоже самое

Fluttershy ()

Каким-то лесом появилось в приложениях NVIDIA X Server Settings

Fluttershy ()
Ответ на: комментарий от Fluttershy

А вы sid и не подключили. Чтобы подключить sid, строчки из sources.list продублируйте и вместо jessie напишите sid.

Deleted ()
Ответ на: комментарий от w1nner

Я хотел тебе сказать, что отключать автозагрузку сервиса и убивать икскы не надо, команда `systemctl stop kdm` и так их убьёт, а отключение не имеет смысла, всё равно потом опять включать после установки?

yurikoles ★★★ ()

Debian, KDE, Nvidia... Ну ты понел, да?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.