LINUX.ORG.RU

Fedora 26 nvidia error

 


0

1

nvidia-installer log file '/var/log/nvidia-installer.log' creation time: Sun Oct 1 12:54:29 2017 installer version: 384.90

PATH: /usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/lord/.local/bin:/home/lord/bin

nvidia-installer command line: ./nvidia-installer

Using: nvidia-installer ncurses v6 user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> Tagging shared libraries with chcon -t textrel_shlib_t. -> License accepted. -> Installing NVIDIA driver version 384.90. -> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: No) -> Performing CC sanity check with CC=«/usr/bin/cc». ERROR: Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option. ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at http://www.nvidia.com.

Ядро 4.12.14-300.fc26.x86_64 хейдеры тоже установлены. Всё делал по инструкции описанной здесь https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

Всё в выхлопе же написано английским по чёрному

Написано, мало хедеров, нужны исходники ('kernel-source' or 'kernel-devel'). Если они стоят, передай путь с параметром --kernel-source-path

Ну и лог с деталями покажи заодно

Gary ★★★★★ ()
Ответ на: комментарий от Gary

какой лог с деталями, и как указать путь к исходникам, как не писал не канало, пишет не правильно пишу команду.

LordRiddle ()
Ответ на: комментарий от Sergius71

вот только сейчас нет звука, подключён кабель hdmi к монитору со встроенными динамиками, и какие тыкалки типа sudo alsactl init не помогают.

LordRiddle ()
Ответ на: комментарий от LordRiddle

звук есть только при подключении аналогово кабеля прямиком в порт мат платы либо на выход передней панели и подключением в монику, но меня такой расклад не устраивает.

LordRiddle ()
Ответ на: комментарий от SergeySVold

Пробил устройства командой aplay -l и по отдельности speaker-test -t wav -c 2 -D hw:1,0+++ и нашёл рабочее 1,8 после в default.pa перед строкой load-module module-udev-detect поставил символом # и добавил в самом низу строку load-module module-alsa-sink device=hw:1,8 сейчас ребутнусь и посмотрю будет звук или нет

LordRiddle ()
Ответ на: комментарий от SergeySVold

при перетаскивании ползунка в контроллере звука видно приложение с источником звука и только при максимальном уровне индикатор слегка бегает в пределах 10% от минимального, но толку не какого, звука просто нет.

LordRiddle ()
Ответ на: комментарий от SergeySVold

ура, проблема решена,в etc/pulse/ в файле default.pa было load-module module-alsa-sink device=hw:1,3 я поставил 1,8 и проблема исчезла, после перезагрузки звук появился. при этом что странно я ведь лично добавил эту строку и выставил с опцией 1,8 и остаётся загадкой каким образом она перевелась на 1,3

LordRiddle ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.