LINUX.ORG.RU

gentoo, evince ~amd64

 ,


0

1

доброго времени суток. хочу поставить evince-3.14.1-r1 и emerge дает такой выхлоп evince тянет за собой gtk-3.14... он тянет glib-2.42.1, а он в свою очередь хочет чтобы был установлен gdbus-codegen-2.42.1. в системе установлен gdbus-codegen-2.40.2 от него зависят:

equery d dev-util/gdbus-codegen-2.40.2 * These packages depend on dev-util/gdbus-codegen-2.40.2:

  • app-text/evince-3.12.2 (dev-util/gdbus-codegen)
  • dev-libs/glib-2.40.2 (>=dev-util/gdbus-codegen-2.40.2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)])
  • gnome-base/gvfs-1.20.3 (dev-util/gdbus-codegen)
  • x11-libs/gtk+-3.12.2 (dev-util/gdbus-codegen)

все кроме gnome-base/gvfs-1.20.3 поменяется, а ему в принципе плевать какой у него gdbus-codegen. добавил в package.accept_keywords

dev-util/gdbus-codegen ~amd64

причем за зря, но устанавливать не хочет все равно. если честно я сам запутался. чяднт? upd добавление dev-util/gdbus-codegen ~amd64 решает «проблему»


Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.