LINUX.ORG.RU

thunar и ftp, smb

 , , ,


0

2

Добрый день.
Имеется машина с Debian Jessie, Xfce & thunar. Так вот, thunar не видит сеть.
Из консоли запускаю - не ругается ни на что...
На другой машине с точно таким-же набором всё работает.
(gvfs-* установлены)
Вопрос: от чего зависит работа сети в thunar?

★★★

Какая ещё сеть в thunar? Это файловый менеджер.

FireFighter ()

Версии одинаковы? Я для ftp юзаю curlftpfs, щаз проверил - все через Thunar работает (1.6.3), в Nerwork появился линк на ftp.

invokercd ★★★★ ()
Ответ на: комментарий от invokercd

Версии тунара одинаковы. Ветка дистрибутива одна и та же.

S_Paul ★★★ ()
Ответ на: комментарий от FireFighter

Нет у тунара логов, я выше писал - в консоль ничего не выводит.
strace пока ничего вразумительного не показывает.

S_Paul ★★★ ()
Ответ на: комментарий от FireFighter

В системе _ВСЁ_ работает. Сеть есть. ftp, ssh работают(из консоли, в mc, в filezilla).
И только thunar(pcmanfm тоже, оказывается) _НЕ_ могут работать с сетью. Ругаются.
Например, если жмакнуть «Обзор сети», выскочит: «Действие не поддерживается.»
Если набирать в строке адреса "ftp://..." - появляется знак «недоступно».

S_Paul ★★★ ()
Последнее исправление: S_Paul (всего исправлений: 1)
Ответ на: комментарий от S_Paul

Такое ощущение, что не доустановлена утилита для поддержания виртуальных сетевых ФС. Названия к сожалению не помню

FireFighter ()
Ответ на: комментарий от S_Paul

How to: Xubuntu - Thunar Native Windows Network Browsing Since Thunar doesn't have native network Browsing, here is a good way to accomplish it:
1) In XFCE's Applications -> System -> Shared Folders. (This should trigger a Samba install if you don't already have a share, and it should allow you to define the proper workgroup)
2) Install fusesmb in Synaptic (from Universe repository)
3) Edit /etc/modules and add the word 'fuse' to the modules list to be loaded (without quotes), and save the file.
4) Reboot, so the fuse module loads, and the proper workgroup is read for samba.
5) In XFCE Applications -> System -> Users and Groups... Properties of your username... User Priveleges Tab... check «Allow use of fuse file systems...»
6) Create a directory that you are going to mount your network browse to... I used /media/network. Change permissions to read / write for group and others (777).
*** 6.5) In a terminal, type: sudo chown <username>:fuse /media/network (Where <username> is your user account logon name)
*** 6.6) Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked.
*** 6.7) Reboot the system and triple check with step 6.6
7) In XFCE Applications -> Settings -> Autostarted Applications... Add an application... name and describe as you wish... for command line, put: fusesmb /media/network (Or whatever mountoint you created).
8) Open Thunar, and navigate to the parent folder of your mountpoint... then drag the 'mounpoint folder' to the places (shortcut) pane of thunar.
9) Logout and log back in (So the user privilege and fusesmb autostart will take affect)
*** Added steps to help prevent some access denied issues some people have been experiencing with fusesmb.

Должно помочь

rinsvid ()
Последнее исправление: rinsvid (всего исправлений: 1)
Ответ на: комментарий от rinsvid

Спасибо, но по-моему это костыль. Thunar умеет работать с win-сетью без плясок, просто есть какой-то нюанс...

Может какая-то зависимость у пакетов не прописана?...

S_Paul ★★★ ()
Ответ на: комментарий от S_Paul

Удалось победить? У меня теже грабли только под Mageia

anonymous ()
Ответ на: комментарий от anonymous

Неа, забил пока. Вот думаю, может что-то мешает ему использовать сеть как таковую? Скорее всего даже не thunar виноват а какие-то системные настройки.

Если найдёте, поделетесь?

S_Paul ★★★ ()
Ответ на: комментарий от S_Paul

На Wiki Debian описано решение:

«Xfce

For network browsing in the thunar file manager, install gvfs-backends and gvfs-fuse, and add your users to the „fuse“ group (sudo adduser <user> fuse).»

https://wiki.debian.org/DebianDesktopHowTo

Лично у меня группы fuse нет, но после установки gvfs-backends и gvfs-fuse thunar стал заходить на samba шару.

ZveRus ()
Ответ на: комментарий от ZveRus

Перепроверил(тогда-же) - не помогло. Буду ещё копать.

С памятью у меня не очень...

S_Paul ★★★ ()
Последнее исправление: S_Paul (всего исправлений: 1)
Ответ на: комментарий от ZveRus

Спасибо тебе, добрый человек! У меня «Обзор сети» тоже заработал после установки gvfs-backends и gvfs-fuse. Юзера в группу «fuse» не добавлял.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо, была такая же проблема. Всё заработало

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.