LINUX.ORG.RU

Как всегда запорол видеодрова

 , ,


0

1

Решил исправить ошибку при запуске системы типа nouveau error no valid vbios found. Почитал что люди используют sgfxi чтобы устанавливать драйвера, инсталляция была очень удобна и крута пока не пришлось запускать. Собственно ничего не запустилось, xorg падал на no screens. Я удалил к чертям xorg.conf (потому что система не имела его до запуска скрипта) и теперь все запустилось, но разрешение 1024x768 видимо что-то не правильно определилось. Можно ли как-нибудь попросить дебиан заново определить оборудование? Ведь при установке он с этим хорошо справлялся

Делаю по этому мануалу: https://wiki.debian.org/ru/Nouveau

Однако при запуске все равно разрешение 1024x768 и при запуске вылазит искаженная картинка Intel, такое впечатления что драйвер левый грузится

echo deb http://ftp.debian.org/debian/ wheezy-backports main >> /etc/apt/sources.list &&
echo deb http://ftp.ua.debian.org/debian/ wheezy contrib non-free main >> /etc/apt/sources.list &&
echo deb-src http://ftp.ua.debian.org/debian/ wheezy contrib non-free main >> /etc/apt/sources.list 
apt-get -y remove --purge xserver-xorg-video-{apm,ati,chips,i128,i740,intel,mach64,mga,neomagic,openchrome,r128,radeon,rendition,s3,s3virge,savage,siliconmotion,sis,sisusb,tdfx,trident,tseng,vmware,voodoo} 
apt-get -y autoremove 
apt-get clean
apt-get -y install  linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms nvidia-glx mesa-utils nvidia-xconfig
nvidia-xconfig
echo blacklist nouveau >> /etc/modprobe.d/blacklist.conf && echo nvidia >> /etc/modules.conf 
reboot
sin-ok ()
Ответ на: комментарий от Chubakur

Удаляй все что делал по той инструкции в первом посте.

apt-get remove --purge libdrm-nouveau1a xserver-xorg-video-nouveau

и почисти /etc/modules запись nouveau удали затем apt-get update

и в путь по моей инструкции

sin-ok ()
Ответ на: комментарий от Chubakur

Давай обновим ядро

apt-get -y install linux-image-amd64 -t wheezy-backports

и apt-get upgrade apt-get dist-upgrade

sin-ok ()
Ответ на: комментарий от sin-ok

иксы стартуют только если я полностью удалю xorg.conf. Тогда они стартуют в неправильном разрешении и отображается при старте искореженный логотип Intel

Chubakur ★★ ()
Ответ на: комментарий от Chubakur

Странно, откуда там intel

Может еще кто подскажет.

sin-ok ()
Ответ на: комментарий от Chubakur

две видюхи, Intel HD 3000 и какая-то nvidia, по всей видимости ноут

может отключить Intel HD

sin-ok ()
Ответ на: комментарий от Chubakur

Хотя я не могу гарантировать что поставил его правильно. Я делал так:

apt-get install bumblebee-nvidia primus
cp /etc/bumblebee/xorg.nvidia.conf /etc/X11/xorg.conf

Chubakur ★★ ()
Ответ на: комментарий от Chubakur

Хотя я сейчас кое-что понял, написано что для работы bumblebee необходимо удалить xorg.conf. Я удаляю, запускается система с логотипом интел, optirun iceweasel запускает прогу. То есть работает? Но разрешение все равно Г

P.S.

chubakur@debian:/var/log$ optirun glxgears -info
primus: fatal: broken GLX on main X display

Chubakur ★★ ()
Последнее исправление: Chubakur (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.