LINUX.ORG.RU

Не запускается xserver после установки проприетарного драйвера.

 , , ,


0

1

После попытки установки проприетарного драйвера на видеокарту Radeon 3000, перестал запускаться xserver.

Логи установки драйвера

/var/log/Xorg.0

Драйвера качал с сайта AMD, пробовал разные версии. Что, собственно, нужно сделать, чтобы заставить его работать?

Система: Debian Wheezy

Radeon 3000
проприетарного драйвера

НО ЗАЧЕМ?!

Драйвера качал с сайта AMD

facepalm.png

Короче, удали это говно и пользуйся нормальным штатным драйвером.

Gotf ★★★ ()
Последнее исправление: Gotf (всего исправлений: 1)
Ответ на: комментарий от Gotf

В случае использования обычного драйвера, отсутствует родное разрешение монитора и не работает большинство эффектов в кедах. Если можно заставить их работать и со штатным драйвером — расскажите как, пожалуйста.

Qazder ()

Radeon 3000

Драйвера качал с сайта AMD

X.Org X Server 1.16.1

Твоя видюха поддерживается только легаси драйвером, который иксы выше чем 1.12 не может. Если хочешь блоб тебе придется откатить иксы. Так что лучше попробуй разобраться со свободными дровами что идут в комплекте с дистром.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Что можно сделать со свободными драйверами, чтобы родное разрешение выставлялось и работали эффекты в KDE? У меня это всё не работало.

Qazder ()
Ответ на: комментарий от Qazder

Что можно сделать со свободными драйверами, чтобы родное разрешение выставлялось и работали эффекты в KDE? У меня это всё не работало.

sudo apt-get install firmware-linux-nonfree
sudo reboot

Enjoy your debian.

Mixail ()
Последнее исправление: Mixail (всего исправлений: 1)
su -c "aticonfig --adapter=all --initial ; killall Xorg"
Dron ★★★★★ ()
Ответ на: комментарий от Qazder

Какого пакета? Ты же руками ставил. Соответственно и удалять надо как-то по-другому. Не забудь потом переустановить пакеты, файлы которых были заменены установщиком fglrx.

Gotf ★★★ ()
Ответ на: комментарий от Qazder

Для начала как тебе уже тут советовали тебе нужно отчистить систему от fglrx драйвера. А потом уже смотреть что конкретно у тебя не так .

Behem0th ★★★★★ ()
Ответ на: комментарий от Gotf

Удалил fgrlx, воспользовавшись /usr/share/ati/fgrlx-uninstall.sh. После этого удалось загрузиться, но только с помощью команды startx.

Теперь у меня 2 вопроса:

  • Как можно вернуть загрузку через менеджер дисплеев?
  • Какой теперь лучше устанавливать драйвер?
Qazder ()
Ответ на: комментарий от Qazder

Какой теперь лучше устанавливать драйвер

Уже написали же: firmware-linux-nonfree. Если хорошо погуглить на тему «linux + radeon» - именно эта инфа и гуглится;-) Дрова с оффсайта если и заработаю, то протащат с собой много других проблем. Вспоминаем историю «windows + radeon».

Как можно вернуть загрузку через менеджер дисплеев

/fixed «загрузка менеджера дисплеев»
А если подумать? Вы его случайно не удалили? Скорее всего нет;-) Если установлен - man update-rc.d
P.S. Товарищ! Если юзаем Linux - нужно учиться думать, периодически включать мозг и учится искать нужную информацию! Хотя это и в жизни часто полезно;-)

Ignatov ★★★ ()
Последнее исправление: Ignatov (всего исправлений: 1)

Новые драйвера не поддерживают карты ниже 4000серии. Ставь fglrx-legacy или сиди на свободных

Agreas ()
Ответ на: комментарий от Behem0th

Поставил firmware-linux-nonfree. Теперь в списке доступных появилось родное разрешение экрана, но эффекты в KDE всё равно не работают (скриншот). Я ими, в общем-то, пользоваться не собирался, но хотелось бы знать причину невозможности их запуска.

Qazder ()
Ответ на: комментарий от Qazder

OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x209)

У тебя не запустился радеон драйвер и вместо него используется софтварный драйвер.

Тебе нужно проверить стоят ли у тебя в системе свободные радеон дрова. Тебе нужно найти и поставить xserver-xorg-video-radeon libgl1-mesa-dri.

В названиях пакетов дебиане не уверен, брал отсюда.

https://wiki.debian.org/AtiHowTo

Behem0th ★★★★★ ()
Последнее исправление: Behem0th (всего исправлений: 1)
Ответ на: комментарий от Behem0th

При попытке установки xserver-xorg-video-radeon:

Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-video-radeon : Зависит: xorg-video-abi-12

E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

При попытке установки xorg-video-abi-12:

Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Пакет xorg-video-abi-12 — виртуальный, его функции предоставляются пакетами:
  xserver-xorg-core 2:1.12.4-6+deb7u2 [Нет версии-кандидата]
E: Для пакета «xorg-video-abi-12» не найден кандидат на установку
Qazder ()
Ответ на: комментарий от Behem0th

Пробовал уже — пишет, что уже установлена самая новая версия.

А так же сообщает, что у меня есть очень много пакетов, которые больше не требуются и предлагает их удалить, при выполнении apt-get autoremove.

apt-get install xserver-xorg-core

Я удалил какой-то пакет, который тянет за собой полсистемы? Если так, то как определить какой именно?

Qazder ()
Ответ на: комментарий от Qazder

Я удалил какой-то пакет, который тянет за собой полсистемы? Если так, то как определить какой именно?

Как работает пакетная система в дебиане я тебе не подскажу. Сам сижу на арче и живого дебиана в глаза не видел.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

А по ссылке которую я выше кидал переходил?

Всё, что там предлагается делать, я уже делал. Пакеты xserver-xorg-video-radeon и xserver-xorg-video-radeon зависят от xorg-video-abi-12. Вывод попытки его установки я уже приводил.

Qazder ()

Тут нужны специалисты по дебиану: что там входит а что не входит в поставку по умолчанию. По идее 3d-драйвер должен находиться в папке /usr/lib/dri а иксовый драйвер в папке /usr/lib/xorg/modules/drivers (за точность не ручаюсь — у меня не дебиан). Посмотри содержимое этих папок и покажи логи Xorg. Судя по dmesg ядерный драйвер работает нормально.

morse ★★★★★ ()
Ответ на: комментарий от morse

у него свраст галлиумный стартует вместо радеоновского драйвера. Это видно по логам что он привел выше. Ему нужно установить xserver-xorg-video-radeon libgl1-mesa-dri, но они не ставятся, так как Не запускается xserver после установки проприетарного драйвера. (комментарий)

тут действительно нужны специалисты по дебиану.

Behem0th ★★★★★ ()
Ответ на: комментарий от Qazder

Всё, что там предлагается делать, я уже делал.

На всякий случай переспрошу пункт первый тоже выполнил?

Add «contrib» and «non-free» components to /etc/apt/sources.list

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

На всякий случай переспрошу пункт первый тоже выполнил?

Да, делал. На всякий случай, вот мой /etc/apt/sources.list

deb http://ftp.de.debian.org/debian wheezy main contrib non-free
deb-src http://ftp.de.debian.org/debian wheezy main contrib non-free
deb http://http.debian.net/debian/ wheezy main contrib non-free

Может тут не хватает чего? Просто, у кого не посмотрю — у них sources.list огромный, на множество строчек.

Qazder ()
Ответ на: комментарий от Qazder

Package: xserver-xorg-core
Versions:
2:1.16.1-1 (/var/lib/dpkg/status)

А ты случайно jessie (testing) не подключал? Похоже на то что подключил обновился а потом отключил.

Behem0th ★★★★★ ()
Последнее исправление: Behem0th (всего исправлений: 1)
Ответ на: комментарий от Behem0th

А ты случайно jessie (testing) не подключал?

Хмм.. Вполне возможно, что и подключал. Вместе с KDE у меня также стоит XFCE — им я пользовался раньше. Кажется, именно там я и подключал testing для установки whisker-menu. Хотя, я не понимаю какое отношение имеет этот компонент к xserver-xorg-core и каким образом я мог его обновить, устанавливая самое обычное меню.

Что теперь можно сделать? Можно откатить пакет до версии из stable? Или может лучше обновиться до Jessie? (Он, кажется, недавно был заморожен). Заработают ли драйвера во втором случае?

Qazder ()
Ответ на: комментарий от Qazder

каким образом я мог его обновить, устанавливая самое обычное меню

Вангую ты просто обновил систему при подключенном теститнге, вот и обновился xserver-xorg-core.

Хотя, я не понимаю какое отношение имеет этот компонент к xserver-xorg-core

У тебя xserver-xorg-core установлен из тестинга и ему нужен xserver-xorg-video-radeon из тестинга. А поскольку у тебя тестинг отключен доступен только xserver-xorg-video-radeon из стайбла, который не подходит по версии.

Можно откатить пакет до версии из stable?

Это стайбл вариант в духе дебиан стейбла.

Или может лучше обновиться до Jessie?

Мне лично этот вариант нравится больше.(но ведь я сижу на арче). Открытые дрова для радеонов пилятся активно и давно известно что чем новее версия тем лучше.

Заработают ли драйвера во втором случае?

Должны, а точно будет известно только после установки.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Как установишь, перезагрузись и вывод glxinfo | grep Open сюда.

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Qazder ()
Ответ на: комментарий от Qazder

Или может лучше обновиться до Jessie?

Да. В плане видеодрайверов разница огромная.

Gotf ★★★ ()
Ответ на: комментарий от Qazder

Новый glxinfo | grep Open

OpenGL renderer string: Gallium 0.4 on AMD RS780

Поздравляю, у тебя свободные AMD дрова, с OpenGL 3.3

Behem0th ★★★★★ ()
Ответ на: комментарий от Qazder

В случае использования обычного драйвера, отсутствует родное разрешение монитора и не работает большинство эффектов в кедах.

Эта проблема устранилась?

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Эта проблема устранилась?

Нужное разрешение появилось сразу, а эффекты не проверял. Сейчас посмотрел — всё работает. Спасибо. Вопрос, вроде как, полностью решён.

Qazder ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.