LINUX.ORG.RU

Wine 1.7 установить в Xubuntu 14

 , , ,


0

1

Всем привет. Необходимо установить ITunes на Хубунте x64(не спрашивайте почему). Для этого я поставил PlayOnLinux, а он говорит, что мой Wine 1.6.2 не поддерживает работу с USB. Я начал гуглить по ссылке «USB wine» Меня кинуло на WINEHQ где патчи только до 1.5 версии вайна. Где-то увидел, что начиная с Wine 1.6.9 USB работает! Начал ставить Wine 1.7 и понеслась

 sudo aptitude install wine1.7
Следующие НОВЫЕ пакеты будут установлены:        
  fonts-horai-umefont{a} libasn1-8-heimdal:i386{a} libcapi20-3{a} libcapi20-3:i386{a} libexif12:i386{a} libgd3:i386{a} libgif4:i386{a} libglu1-mesa:i386{a} libgphoto2-6:i386{a} 
  libgphoto2-port10:i386{a} libgssapi3-heimdal:i386{a} libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a} 
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libieee1284-3:i386{a} libkrb5-26-heimdal:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} 
  libopenal1:i386{a} libosmesa6{ab} libosmesa6:i386{ab} libpcap0.8:i386{a} libroken18-heimdal:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} 
  libusb-1.0-0:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a} libxinerama1:i386{a} libxpm4:i386{a} 
  libxrandr2:i386{a} ocl-icd-libopencl1:i386{a} p11-kit-modules:i386{a} p7zip{a} wine-gecko2.24{a} wine-gecko2.24:i386{a} wine-mono4.5.2{a} wine1.7 wine1.7-amd64{a} wine1.7-i386:i386{a} 
  winetricks{a} 
Следующие пакеты будут обновлены:
  libglapi-mesa{b} 
1 пакетов обновлено, 52 установлено новых, 0 пакетов отмечено для удаления, и 14 пакетов не обновлено.
Необходимо получить 136 MБ/150 MБ архивов. После распаковки 502 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libegl1-mesa-drivers : Зависит: libglapi-mesa (= 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty.
 libglapi-mesa : Ломает: libglapi-mesa:i386 (!= 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty) но установлен 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty.
 libglapi-mesa:i386 : Ломает: libglapi-mesa (!= 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty.
 libgles2-mesa : Зависит: libglapi-mesa (= 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty.
 libgl1-mesa-glx : Зависит: libglapi-mesa (= 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty.
 libosmesa6 : Ломает: libosmesa6:i386 (!= 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty.
 libosmesa6:i386 : Ломает: libosmesa6 (!= 10.4.0~git20141103.799106d3-0ubuntu0ricotz~trusty) но будет установлен 10.4.0~git20141106.ba0bb422-0ubuntu0ricotz~trusty.
Следующие действия разрешат зависимости:

       Удалить следующие пакеты:                                                           
1)       abiword                                                                           
2)       abiword-plugin-grammar                                                            
3)       abiword-plugin-mathview                                                           
4)       amarok                                                                            
5)       amarok-utils                                                                      
6)       audacity                                                            
*****************************************                       
     
206)     libegl1-mesa рекомендует libegl1-mesa-drivers  
Делал следующее
aptitude update;aptitude upgrade
Не касался только aptitude dist-upgrade, потому что она хочет мне снести нужные на данный момент пакеты(в частности skype. Я сейчас далеко от дома, и это единственное средство связи).

Если ты хочешь музыку на гейпод перекинуть, то оно ни в каком вайне работать не будет, можешь не париться.

Какой-то кривой в твоей бубунте мультиарч, однако, все ломается, грусть-печаль.

Freyr69 ★★★ ()

поставь винду в виртуалку и пробрасывать usb, правда у меня проброс usb в virtualbox работает только если запустить virtualbox от рута

Nuzhen_tolko_lin ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.