LINUX.ORG.RU

Не работает LED индикатор клавиатуры при переключении раскладки

 


0

1

Раньше везде и всегда (сколько я помню) была возможность при переключении раскладки выставить указание, чтобы переключалася LED-индикатор на клавиатуре при смене раскладки (например, индикатор CapsLock).

При переходе на Ubuntu 14.04 эта возможность пропала. В gnome-tweak-tool есть соответствующая опция, но она успешно не работает, да и сам этот утиль выглядит теперь весьма странно. Похоже это проблема именно gnome.

Собственно говоря: Что делать?

Потому что: отсутствие этой мелочи вызывает дикое раздражение.

Update: Возможно это важно. В качестве переключалки использую CapsLock

Update 2: Там, где у меня всё работает и стоит fvwm оказывается всё ещё под версией 12.04, так что проблема может быть более глобальной.

★★★★★

Раньше везде и всегда

4.2

Штатный плагин раскладок xfce не даёт загораться led (настроенному через иксы).

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 1)
Ответ на: комментарий от Eddy_Em
> setleds +scroll
KDGKBLED: Неприменимый к данному устройству ioctl
Ошибка чтения текущего состояния индикаторов. Возможно, вы не в консоли?
Evgueni ★★★★★ ()
Ответ на: комментарий от Black_Roland

А патч есть? Этот баг весит похоже больше года со времён 13.10 и ответственные ничего не хотят делать так как «большинству это не нужно».

Evgueni ★★★★★ ()
Последнее исправление: Evgueni (всего исправлений: 1)
Ответ на: комментарий от Evgueni

Нет, вы можете его создать или создать в директории /etc/X11/xorg.conf.d файл с секцией, в которой описать лишь настройки клавиатуры и переключение раскладок с индикацией переключения. С другой стороны можете сгенерировать xorg.conf целиком.

kostik87 ★★★★★ ()
Ответ на: комментарий от Evgueni

Как то так, только xkboptions свой подставить

% cat /etc/X11/xorg.conf.d/xorg.conf                                                    
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "us,ru"
        Option "XkbVariant" ","
        Option "XkbOptions" "grp:shifts_toggle,grp:caps_switch"
EndSection

disarmer ★★★ ()
Ответ на: комментарий от disarmer
Option "XkbLayout" "us,ru"
Option "XkbVariant" ","
Option "XkbOptions" "grp:shifts_toggle,grp:caps_switch"

Эти все настройки лучше прописывать в /etc/default/keyboard. Или воспользоваться

dpkg-reconfigure keyboard-configuration
dpkg-reconfigure console-setup
Zubok ★★★★★ ()
Ответ на: комментарий от Evgueni

А в иксах через xset включается?

$ xset led named "Caps Lock"

Или вместо named CapsLock цифры попробуй 1, 2, 3. Выключить - это -led (с минусом).

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Как доберусь до домашней машины — поэксперементирую.

Evgueni ★★★★★ ()

это ж ещё года 4 назад в самих иксах ломали. у меня в 14,04 по setxkbmap -layout 'us,ru' -option 'grp:caps_toggle' led загорается, но не отключается, когда меняешь фокус на окно с другой раскладкой.

thunar ★★★★★ ()
Ответ на: комментарий от thunar

ага, точно. только теперь два индикатора загораются.

Какие? Может, сконфигурирован какой где-то еще?

Zubok ★★★★★ ()

Натурально, гномовскую переключалку опять сломали, да так концептуально что даже svu забил ремонтировать...

sin_a ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.