LINUX.ORG.RU

chrome vs ubuntu vs composite vs nvidia blob

 , , , ,


0

1

с момента обновления на trusty, в чроме появился неприятный баг.

вводные: openbox, в нем запущен наутилус (рисует десктоп — т.е. фон, иконки, и т.п.), xorg.conf отсутствует, композитного менеджера нет.

если чром развернуть (maximize), а потом попробовать его минимизировать, или переключиться на другой рабочий стол — происходит странное, как будто окно осталось видимым, но неактивным, мерцает, неактивно, и т.п.

если окно не максимизировать, то минимизация и переключение рабочих столов работают корректно.

экспериментальным путем удалось выяснить, что помогает запуск xcompmgr, проблема исчезает полностью. в убунтовой виртуалке проблемы нет, так что невидия, видимо, замешана.

кто-нибудь еще сталкивался? может есть какой-то способ это пофиксить без запускания xcompmgr?

★★★★★

что за упоротое название темы? ты знаешь что означает «vs»?

с момента обновления на trusty

ты думаешь тут все знают как именуются версии убунты? лол

xorg.conf отсутствует
nvidia blob

ну так сгенерируй его, в чем проблема?

reprimand ★★★★★ ()

А что мешает запускать xcompmgr? xcompmgr -cC не напрягает всякими анимациями емнип, только тени рисует.

NeverLoved ★★★★★ ()

И какая версия блоба?

Потушил сейчас compton, проблем с хромиумом не наблюдаю.
awesome-3.5.4
nvidia-drivers-337.12

NeverLoved ★★★★★ ()
Ответ на: комментарий от NeverLoved

А что мешает запускать xcompmgr? xcompmgr -cC не напрягает всякими анимациями емнип, только тени рисует.

в данный момент так и делаю. мешает то, что делать этого не хочу. никакие тени, ессно, не рисует. просто бесполезная запущенная программа.

И какая версия блоба?

пробовал 331 и 304, проблема одинаковая.

проблем с хромиумом не наблюдаю.

у меня гуглхром бета. возможно, проблема только в гуглхроме, но не в хромиуме. я хромиум не пробовал.

waker ★★★★★ ()

B все-таки или Хром (по-русски) или Кром (по агл). «Чром» режет слух )

powerguy ★★★ ()

Пару недель назад на Генте собирал хромиум без aura, в virtualbox, xfce, адские глюки и мерцания webview, с выключенным аппаратном ускорением в браузере - все нормально.

bhfq ★★★★★ ()
Ответ на: комментарий от ipeacocks

compton в генте раньше был только 9999, а xcompmgr - нормальный, вот я и назвал по старой памяти.

Да и зачем использовать инструмент против тиринга без тиринга?

NeverLoved ★★★★★ ()
Ответ на: комментарий от ipeacocks

xcompmgr разве не дохлый? есть же compton

по теме топика это не играет роли. вопрос был о том, как решить проблему без запускания композитора. проблема, кстати, так и не решена.

waker ★★★★★ ()
Ответ на: комментарий от ipeacocks

Был осом и есть осом, не было тиринга - появился, хехе.

У меня даже система одна и та же была - после смерти ноутбука вынул из него винт и вставил в свежесобранный десктоп. Так что, в данном случае, DE совершенно ни при чём.

NeverLoved ★★★★★ ()
Последнее исправление: NeverLoved (всего исправлений: 1)

мне только что написали в ирке, что этот баг исправили в драйвере nvidia. буду проверять вечером :)

waker ★★★★★ ()
Ответ на: комментарий от ipeacocks

у меня только xfce, больше ставить ничего не хочу.

я и не предлагал ничего другого ставить. просто запустить тот же xcompmgr или compton, и проверить не пропадет ли баг.

но вообще именно с таким багом я не сталкивался.

waker ★★★★★ ()
Ответ на: комментарий от ipeacocks

а сам хром какой версии? у меня 35я если что. никаких проблем нет, кроме (в прошлом) вот этой что в топике.

waker ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.