LINUX.ORG.RU

а где чейнджлог?

anonymous ()

До чего ж противно видеть мылору и линукс в одном предложении.

thesis ★★★★★ ()
Ответ на: комментарий от nutsandmilk

В данный момент Десктопный клиент это просто бинарь, инсталятора пока нет.

krivenkov ()
Ответ на: комментарий от das_tier

Можно сказать и новость, т.к. предыдущая версия под Линукс была 4-х месячной давности.

krivenkov ()
Ответ на: комментарий от krivenkov

Десктопный клиент это просто бинарь, инсталятора пока нет.

Сурово. Без гуя ещё небось?

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

С гуем конечно )). Только под Ubuntu проблемы с иконкой в трее.

krivenkov ()
Ответ на: комментарий от krivenkov

Только под Ubuntu проблемы с иконкой в трее.

Ну вот, а я чуть было не обрадовался. И что за проблемы?

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Что бы иконка появилась в трее под Ubuntu, надо: sudo add-apt-repository ppa:timekiller/unity-systrayfix sudo apt-get update sudo apt-get upgrade gsettings set com.canonical.Unity.Panel systray-whitelist «['all']»

krivenkov ()

Добровольно ставить их зловред? Это шутка?

Deleted ()
Ответ на: комментарий от krivenkov

Судя по размеру, статически слинкованный. Существует решение как делать динамические бинари так, чтобы на разных системах не получать ошибки «не найдена библиотека», и каждый раз разная. LSB 4.0 - компилим в CentOS 5, кладём в каталог lib зависимости, вычитаем эти файлы, пишем скрипт запуска run.sh. Поддержка Linux Standard Base есть во всех десктопных линуксах, например в Ubuntu фиг бы запустился Adobe Flash без неё, а также всё остальное проприетарное ПО. Примерно так же работает Steam Runtime, только базируется не на CentOS, а на Ubuntu, и охватывает больше системных библиотек.

Компилятор тоже можно обновить, в CentOS есть удобный способ установить GCC 4.8, чтобы компилить софт в нём. Так как Glibc остаётся 2.4, полученные бинарники будут работать в старых системах. Нужно только в lib положить libstdc++.so.6 от GCC 4.8.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Спасибо. Постараемся это сделать в ближайшее время.

krivenkov ()

А вебдав наверно и не включат никогда.

Medar ★★★★★ ()
Ответ на: комментарий от Medar

Пока не могу сказать ничего определенного по поводу вебдава.

krivenkov ()
Ответ на: комментарий от pekmop1024

Пока не могу сказать ничего определенного по поводу вебдава.

krivenkov ()
Ответ на: комментарий от krivenkov

А сорцы будут?

ОЧЕНЬ стремно ставить и запускать что либо мейлрушное в своем уютненьком.

roman77 ★★★★★ ()
Ответ на: комментарий от krivenkov

Материала по этому должно быть полно. Вот например моё. Если кратко - пока не придумали LSB, в системном /usr/lib лежала только какая-нибудь одна версия какой-нибудь библиотеки, поэтому бинарники от Mandriva не подходили к SUSE, и даже к другому релизу Mandriva. А теперь в /usr/lib лежат сразу две версии одной библиотеки, старая и новая. Новая - для всего открытого ПО, его же всегда можно пересобрать. Старая - для всего закрытого ПО: флеш, скайп, неро, майя и так далее. Именно поэтому эти программы работают в любом линуксе 2007 года и новее. Кстати, обновите ICQ for Linux beta, там «Сертификат просрочен», чтобы установить приходится отматывать дату на 2011 год.

Динамическая линковка это не только 3-мегабайтый бинарник вместо 30-мегабайтного, это ещё и сетевая безопасность. Openssl и прочие билиотеки иногда обновляются, там закрываются сетевые уязвимости. Статически слинкованный бинарник спустя 5 лет после релиза - дуршлаг, и конечный пользователь не сможет это исправить. Динамический будет использовать периодически обновляемые Openssl 0.9.8 и другие библиотеки. А чтобы он запускался через 5 лет нужно или все библиотеки таскать с собой, или сборать бинарник под LSB, а с собой таскать только то что LSB не охватывает: более новый Qt, если 4.3 слишком старый для нашего кода, более новый GTK, если 2.10 старый. С играми любят положить libSDL 1.2, OpenAL и NVIDIA Cg.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 3)
Ответ на: комментарий от krivenkov

Пока не могу сказать ничего определенного по поводу вебдава.

Это очень печально. Потому что реальной пользы от облаков без вебдава в разы меньше. Нет, вы можете накостылять свой davfs2-подобный костыль, тогда будет ок. Но зачем, когда есть вебдав?!

pekmop1024 ★★★★★ ()
Ответ на: комментарий от roman77

Справедливости ради, такое впечатление, что идеологов и авторов гуарда, спутника и тулбаров к мылорушному облачку не подпускают на расстояние пушечного выстрела.

pekmop1024 ★★★★★ ()

Выпущена новая версия десктопного клиента для ненужно Ненужно@ненужно.
Скачать можно отсюда: https://ненужно https://ненужно

Без webdav - нафиг не упало такое облако с проприетарным клиентом, да еще и от чудо-компании которая на весь рунет известна своим говнософтом с говнозондами.

NeverLoved ★★★★★ ()
Ответ на: комментарий от pekmop1024

Так версии спутника и guard под динукс нету, разве что вайн тащить за облачным бинарем.
/толсто

NeverLoved ★★★★★ ()
Ответ на: комментарий от NeverLoved

На винде на первый взгляд тоже внутри не нашлось такого.
Хотя чем этот клиент на самом деле занимается, одним авторам известно.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от pekmop1024

такое впечатление, что идеологов и авторов гуарда, спутника и тулбаров к мылорушному облачку не подпускают на расстояние пушечного выстрела.

Еще не вечер.

roman77 ★★★★★ ()

Сервиса Облако@mail.ru для Linux

Аж глаз задергался, а вместе с ним всякие спутники тоже идут?

Ненужно.

Licwin ★★★★★ ()

это просто прекрасный тред-детектор зашкваренных вендой, лол

anonymous ()
Ответ на: комментарий от Licwin

В данный момент Десктопный клиент это просто бинарь, инсталлятора пока нет.

krivenkov ()

Мало того, что @Mail.ru, да еще и без сорцов. Ха!

Jayrome ★★★★★ ()

можно было бы поставить так ради интереса, если майлру будет начислять выгодную пользователю некоторую сумму в биткойнах на указанный кошель за использование сервисов вместе с клиентом... но даже при этом, хочется исходников вместе с ебилдами (без всякой бинарщины), ибо доверия очень мало...

anonymous ()

у yandex'a уже всё есть. Webdav, SDK, API.

P.S. и всё это ненужно. Закрытое, небезопасное, конская EULA. В общем новый тренд: «ооооблако», спешите расхватать все пирожки.

anonymous ()

Без вебдава пусть катятся ко всем чертям.

geometer ()

оно ещё и обновляется само - это совсем треш, господа

megabaks ★★★★ ()

А есть инструкция по ключам командной строки и способу автозапуска? Логин с паролем оно не сохраняет, с десктопными сервисами хранения паролей вроде kwallet не работает, найденные в гугле способы не работают. Отвлекаться на ввод логина с паролем при входе в систему очень раздражает.

lizard ★★ ()
Ответ на: комментарий от lizard

У Вас авторизация не сохраняется после рестарта? Приложенька должна сама авторизоваться если уже был осуществлен вход и задана папка для синхронизации.

krivenkov ()
Ответ на: комментарий от krivenkov

Вы из маилру? В проге глюк жуткий, она пытается сама себя обновить но что-то наверно идёт не так и этот процесс зациклен сам на себе. Линукс-минт, версия i386 если что. В остальном работает.

anonymous ()
Ответ на: комментарий от ZenitharChampion

Зачем это всё если всем известно что хорошие программы распространяются в исходниках ?

yakunprufovnebudet ()
Ответ на: комментарий от anonymous

на дебиане такой же глюк наблюдаю. причем синхронизация не осуществляетя до завершения обновления. замкнутый цикл

saibogo ★★ ()
Ответ на: комментарий от yakunprufovnebudet

Программы, которые распространяются в исходниках, ты попробуй запусти через 5 лет после релиза. Doom III, Unreal Tournament 2004, Quake IV, Penumbra, Amnesia, Trine, Cold War выпущены много лет назад, а запускаются и сейчас на любой системе.

В чём секрет? Собери из исходников Doom III или Penumbra. А теперь попробуй запустить игру с помощью твоего бинарника на любом другом линуксе. Не запускается? Ну вот видишь. Если не собрать «Облако» по стандарту LSB, он тоже не будет запускаться у большинства пользователей через несколько лет.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от pekmop1024

Редиски, включите вебдав.

Присоединяюсь. На второй день моего теста вырубили...

Jurik_Phys ★★★★★ ()

Давай так: вы нам сырцы, а мы не пишем на вас в EFF и Столлману :) Это win-win.

CLU ()
Ответ на: комментарий от ZenitharChampion

Программы, которые распространяются в исходниках, ты попробуй запусти через 5 лет после релиза.

Через 5 лет никто не мешает поправить пару строк в исходнике. Это лучше, чем запускать через эмуляторы и мультилибы, потому что библиотеки, тулкиты и архитектуры за это время сменились 10 раз.

vurdalak ★★★★★ ()

WebDAV, или не нужно.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.