LINUX.ORG.RU
ФорумAdmin

OpenWrt не добавляет маршрут из конфига

 ,


0

1

Для того что бы OpenWrt мог выходить в интернет мне надо прописать 4 дополнительных маршрута, через SSH/Telnet все прописывается хорошо, но не идти же в консоль после каждого отключения интерфейса, я добавил в /etc/config/network такой код:

config route
	option interface 'wan'
	option target '169.254.0.0'
	option netmask '255.255.0.0'
	option gateway '0.0.0.0'
	option metric '100'

config route
	option interface 'wan'
	option target '109.226.250.5'
	option gateway '0.0.0.0'

config route
	option interface 'wan'
	option target '109.226.250.0'
	option netmask '255.255.255.0'
	option gateway '94.73.231.183'

config route
	option interface 'wan'
	option target '0.0.0.0'
	option netmask '0.0.0.0'
	option gateway '109.226.250.5'

И тут возникла проблема, первые три маршрута добавляются, а последний не хочет, и интернет не работает собственно.

покажи ip route до(когда не руками) и после добавления(когда руками)

видимо, это дефолт-роут
попробуй убрать последний маршрут, а в /etc/config/network добавить

option defaultroute '1'
для wan интерфейса

ii343hbka ★★★ ()
Последнее исправление: ii343hbka (всего исправлений: 1)
Ответ на: комментарий от ii343hbka
root@OpenWrt:/etc/config# ip route
109.226.250.0/24 via 94.73.231.183 dev eth1  proto static 
109.226.250.5 dev eth1  proto static  scope link 
169.254.0.0/16 dev eth1  proto static  scope link  metric 100 
192.168.1.0/24 dev br-lan  proto kernel  scope link  src 192.168.1.1 
root@OpenWrt:/etc/config# route add -net 0.0.0.0 netmask 0.0.0.0 gw 109.226.250.
5 eth1
root@OpenWrt:/etc/config# ip route
default via 109.226.250.5 dev eth1 
109.226.250.0/24 via 94.73.231.183 dev eth1  proto static 
109.226.250.5 dev eth1  proto static  scope link 
169.254.0.0/16 dev eth1  proto static  scope link  metric 100 
192.168.1.0/24 dev br-lan  proto kernel  scope link  src 192.168.1.1 

Опцию добавлял, лучше не стало.

mishkapp ()

И тут возникла проблема, первые три маршрута добавляются, а последний не хочет, и интернет не работает собственно.

У тебя здесь вообще какой-то дикий бардак с роутингом.

dvl36 ()
Ответ на: комментарий от mishkapp

Да уж... Видимо парсер конфига openwrt обладает некоторым интеллектом и впадает в ступор от такого роутинга.

Даже не знаю. Местами что ли поменяй, первый с последним.

dvl36 ()

попробуй убрать tatget и netwask, а оставить только интерфейс и шлюз
ну я имею ввиду из описания маршрута

а wan интерфейс - pppoe?

ii343hbka ★★★ ()
Последнее исправление: ii343hbka (всего исправлений: 2)
Ответ на: комментарий от ii343hbka

Не помогло. Между прочим, сейчас с нуля накатил прошивку, и через люсю прописал маршруты, добавились ВСЕ, но при рестарте интерфейса опять криво все.

wan - dhcp

mishkapp ()
Ответ на: комментарий от ii343hbka
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

config route
        option interface 'wan'
        option target '169.254.0.0'
        option netmask '255.255.0.0'
        option gateway '0.0.0.0'
        option metric '100'

config route
        option interface 'wan'
        option target '109.226.250.5'
        option gateway '0.0.0.0'

config route
        option interface 'wan'
        option target '109.226.250.0'
        option netmask '255.255.255.0'
        option gateway '94.73.231.183'

config route
        option interface 'wan'
        option gateway '109.226.250.5'
        option target '0.0.0.0'
        option netmask '0.0.0.0'

root@OpenWrt:~# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br-lan state UP qlen 1000
    link/ether 64:70:02:cf:28:cf brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 64:70:02:cf:28:d1 brd ff:ff:ff:ff:ff:ff
    inet 94.73.231.183/32 brd 255.255.255.255 scope global eth1
38: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 64:70:02:cf:28:cf brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
39: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 32
    link/ether 64:70:02:cf:28:d0 brd ff:ff:ff:ff:ff:ff
mishkapp ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.