LINUX.ORG.RU
ФорумAdmin

Как лучше объединить несколько компьютеров в одну виртуальную сеть?

 , , , ,


0

2

Я сейчас ищу годные бесплатные VPN, но, наверное, я копаю не в ту сторону.
Есть десяток компьютеров, географически они находятся в разных местах, провайдеры разные, может быть NAT и динамический IP, везде линукс, но дистры разные.
Цель: завязать их в одну виртуальную сеть (такую, чтобы я всегда смог бы подключиться к любому из них с любого из них по ssh без особого колдовства).
Сейчас нашёл tinc. Это то, что мне нужно? Или есть что-то лучше?

★★★★★

Почему вариант со своим openvpn-сервером не рассматриваете? 150 рублей в месяц - смешная сумма.

winlook38 ★★ ()
Ответ на: комментарий от winlook38

Все этот вариант предлагают. Мне лень. У меня есть VPS, на ней Debian 6, под неё нужно этот ваш OpenVPN собирать, чтобы убрать лишние зависимости.

CYB3R ★★★★★ ()
Ответ на: от CYB3R

Ну хоть самому что ли поднять бесплатный openvpn для LORовских лентяев и доступ раздавать по инвайтам в соответствующем разделе :)

winlook38 ★★ ()
Ответ на: от CYB3R

хм tins поднять не лень..

кстати просьба потом поделиться опытом...

как вариант еще можно на каждой машине поднять ipv6 (куча вариантов)

aeX1pu2b ()
Ответ на: комментарий от winlook38

кстати это мысель - даещь частную приват сеть для ЛОРа :) !!!!!

aeX1pu2b ()
Ответ на: комментарий от CYB3R

У меня есть VPS, на ней Debian 6, под неё нужно этот ваш OpenVPN собирать, чтобы убрать лишние зависимости.

что за ересь?

xtraeft ★★☆☆ ()
Ответ на: комментарий от winlook38

Нда, что-то у меня repos.openvpn.net не работает.

CYB3R ★★★★★ ()
Ответ на: комментарий от xtraeft

Зависимости: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.3.2), liblzo2-2, libpam0g (>= 0.99.7.1), libpkcs11-helper1 (>= 1.05), libssl0.9.8 (>= 0.9.8m-1), openssl-blacklist (>= 0.4), openvpn-blacklist, net-tools

xtraeft ★★☆☆ ()
Ответ на: комментарий от xtraeft
The following NEW packages will be installed:
  libexpat1{a} liblzo2-2{a} libpkcs11-helper1{a} mime-support{a} 
  openssl-blacklist{a} openvpn openvpn-blacklist{a} python{a} 
  python-minimal{a} python2.6{a} python2.6-minimal{a} 
0 packages upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.1 MB of archives. After unpacking 32.0 MB will be used.
Do you want to continue? [Y/n/?] 
CYB3R ★★★★★ ()

Тебе нужен miredo, teredo... Бесплатно, и не надо VPN.

А с винды 7, вообще подцепишься без установки чего-либо в таком случае даже.

DALDON ★★★★★ ()
Последнее исправление: DALDON (всего исправлений: 1)
Ответ на: комментарий от CYB3R

У меня для тебя плохие новости:

apt-cache rdepends apt | grep python
python-minimal ничем особенно не мешает. Ставь и не морочь себе и другим голову.

beastie ★★★★★ ()
Ответ на: комментарий от CYB3R

Ну это ты уже сам пож-та погугли... Не знаю насчёт NМ, но в целом не вижу проблем - будет работать, это же просто ipv6 белый адрес. Поставишь на него AAAA запись и го!

DALDON ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.