LINUX.ORG.RU

ssh тунель

 


0

1

Помогите настроить ssh тунель. Есть компьютер за NAT провайдера, vps и телефон.
Набираю на компьютере

ssh -f -N -R 2222:127.0.0.1:22 root@vps
Вроде соединяется, а с телефона подключиться не могу.

пытаешься коннектиться на хост vps и порт 2222? ну зайди на впс, посмотри, поднялся ли там туненель. запусти tcpdump и посмотри, идет ли коннект.

vvviperrr ★★★★★ ()
Ответ на: комментарий от vvviperrr

Да на vps c телефона пытаюсь на 2222 подключиться. Запустил tcpdump, а там строки как из пулемета вылетают. Такого плана

05:00:03.039538 IP x.x.x.x.58178 > vps.ssh: Flags [.], ack 832016, win 1444, options [nop,nop,TS val 3533934397 ecr 253631344], length 0
05:00:03.039830 IP x.x.x.x.58178 > vps.ssh: Flags [.], ack 832664, win 1444, options [nop,nop,TS val 3533934397 ecr 253631345], length 0
05:00:03.040515 IP x.x.x.x.58178 > vps.ssh: Flags [.], ack 833312, win 1444, options [nop,nop,TS val 3533934398 ecr 253631346], length 0
05:00:03.041344 IP x.x.x.x.58178 > vps.ssh: Flags [.], ack 833744, win 1444, options [nop,nop,TS val 3533934398 ecr 253631348], length 0
05:00:03.041428 IP vps.ssh > x.x.x.x.58178: Flags [P.], seq 834464:835304, ack 601, win 102, options [nop,nop,TS val 253631352 ecr 3533934398], length 840
05:00:03.042384 IP vps.ssh > x.x.x.x.58178: Flags [P.], seq 835304:835520, ack 601, win 102, options [nop,nop,TS val 253631353 ecr 3533934398], length 216


 

JoyceGraham ()
Ответ на: комментарий от JoyceGraham

Странно, сейчас попробовал на vps

ssh localhost_user@127.0.0.1 -p 2222

И соединился с локальным компьютером. А с телефона не выходит.

JoyceGraham ()
Ответ на: комментарий от JoyceGraham

Попробовал так, выхлоп не изменился

Но netstat то изменился? Предыдущий точно мог разрешать соединение только на 127.0.0.1. Для начала пробуйте соединятся локально, но на внешний адрес.

vodz ★★★★★ ()
Ответ на: комментарий от zolden
 lsof -i :2222 
COMMAND  PID USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME
sshd    1585 root    7u  IPv6 84386317      0t0  TCP localhost:2222 (LISTEN)
sshd    1585 root    8u  IPv4 84386318      0t0  TCP localhost.localdomain:2222 (LISTEN)
JoyceGraham ()
Ответ на: комментарий от JoyceGraham

Тоже самое.

Какой-то тяжелый случай. Теоретически, вам ведь достаточно порт-редиректором для TCP прокинуть, раз уж внутри тоже ssh. Может так будет проще, через iptables или простейшим порт-редиректором?

vodz ★★★★★ ()
Ответ на: комментарий от JoyceGraham

Кстати, у себя проверил — работает.

ssh -f -N -R $VPS:2222:127.0.0.1:22 $VPS

Ясен пень, после добавления GatewayPorts yes до подачи сигнала SIGHUP sshd тоже вешалось на 127.0.0.1 (хоть бы предупреждало как-то...).

vodz ★★★★★ ()
Последнее исправление: vodz (всего исправлений: 2)
Ответ на: комментарий от JoyceGraham

Может на vps 2222 порт закрыт для внешних подключений?

Для начала добейтесь, чтобы netstat точно говорил, что 2222 порт слушается на всех или внешних адресах. Вы точно давали SIGHUP на vps sshd, чтобы он перечитал конфиг после добавления опции?

vodz ★★★★★ ()
Последнее исправление: vodz (всего исправлений: 1)
Ответ на: комментарий от vodz

Получилось, дурья моя башка. Я GatewayPorts добавил в /etc/ssh/ssh_config, а надо было в /etc/ssh/sshd_config.
Как добавил, все заработало. Спасибо за помощь.

JoyceGraham ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.