LINUX.ORG.RU

Настройка nginx + php-fpm

 , ,


0

2

Всем привет. Прошу помощи. Настраиваю на VPS себе сервер.

Поставил php-fpm и nginx. Вот такие настройки

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
        worker_connections 768;
        # multi_accept on;
}

http {
        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        gzip on;
        gzip_disable «msie6»;

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}
...

Настройки хоста /etc/nginx/sites-available/site (линк на sites-enabled)

server {
        listen   80;

        server_name _;
        root  /var/www/site/www;
        index  index.php;

        error_log  /var/www/site/logs/error.log;

        location ~ \.php$ {
                fastcgi_pass unix:/var/run/php5-fpm.sock;
#                fastcgi_pass 127.0.0.1:9000;
                fastcgi_split_path_info ^(.+\.php)(.*)$;
                fastcgi_index index.php;
                include fastcgi_params;
        }
}

В пхп.ини cgi.fix_pathinfo=0 Закинул в /var/www/site/www/index.php с phpinfo()

Брайзер отдает Велкам ту нгинс (304). В логах нгинса ошибок нет. Подскажите, в чем беда?

Попробуй в хост добавить что-то вроде

    location / {
        index index.php index.html index.htm;
    }

blind_oracle ★★★★★ ()

впиши в секцию server access_log и error_log и проверь попадаешь ли ты туда при запросе

        listen   80;

        server_name _;

а нет ли там какого нибудь default конфига, который биндит тоже самое?

Skolotovich ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.