LINUX.ORG.RU
ФорумAdmin

Не могу установить zend optimiser

 ,


0

1

Проблема следующая: для одной CMS требуется zend optimizer. Техподдержка сказала, что они поддерживают только .rpm и .deb-based дистрибутивы, поэтому поставил в виртуалку ubuntu server 12.04(64-битный), отметил в инсталляторе LAMP, после поставил Zend Framework. Распаковал установщик cms в /var/www. Вижу:

This file was encoded by the Zend Guard. In order to run it, please install the Zend Optimizer (available without charge), version 3.0.0 or later.

Скачал отсюда сначала Zend Guard Loader для php 5.3, но после прописывания путей к .so в php.ini и перезапуска апача ничего не изменилось. Пришлось скачивать оттуда же сам Guard. Инсталлятор сначала ругался на отсутствующую jav'у, но получилось подсунуть ему системный рантайм, как описано здесь. После этого инсталляция была успешно завершена, но по прежнему ничего не изменилось. Посмотреть бы, куда и что сует этот бинарный инсталлер

★★★★

Брось каку, нечего юзать хрен знает какой шифрованный код, есть 100500 открытых цмс на php.

По теме: смотри вывод phpinfo, там должна появится информация о лоадерах если ты их правильно установил, с вероятностью 99% ты что то не правильно прописал в php.ini, или не в тот :)

winddos ★★★ ()
Ответ на: комментарий от winddos

а как примерно должно отобразиться?

Сейчас всё, что связано с Zend, это

Additional .ini files parsed	/etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/zend-framework.ini
PHP API	20090626
PHP Extension	20090626
Zend Extension	220090626
Zend Extension Build	API220090626,NTS
PHP Extension Build	API20090626,NTS
Debug Build	no
Thread Safety	disabled
Zend Memory Manager	enabled
Zend Multibyte Support	disabled

И еще копирайт зенда внизу страницы. Правда,всё это связано с самим фреймворком, который поставил apt-get'ом. Странно, что zendOptimizer'а нет для php>5.2, только ZendGuardLoader дальше. Попробую откатить php до 5.2 и поставить.

Сам бы ни за что такую cms не стал использовать, но под неё плагин просили написать

wingear ★★★★ ()
Ответ на: комментарий от wingear

Должна быть именно категория с лоадером.
По сути ты просто что то коряво прописал в .ini
Просто у меня ни разу ни на одной платформе проблема с лоадерами не было.

winddos ★★★ ()

Оптимайзер не поддерживает 5.3 ветку все еще, так что тебе надо сдаунгрейдить пхп. Гугли php 5.2 ubuntu 12.04.

После того, как понизишь версию, ставь сам зенд:
wget http://downloads.zend.com/optimizer/3.3.9/ZendOptimizer-3.3.9-linux-glibc23-x...
tar xvzf ZendOptimizer-3.3.9-linux-glibc23-x86_64.tar.gz
cp ZendOptimizer-3.3.9-linux-glibc23-i386/data/5_2_x_comp/ZendOptimizer.so /usr/lib/php/modules/

и добавь в /etc/php5/apache2/php.ini или куда тебе там надо строки:
[Zend]
zend_extension=/usr/lib/php/modules/ZendOptimizer.so

Потом рестартни апач, если апач это.

tazhate ★★★★★ ()
Ответ на: комментарий от winddos

Брось каку, нечего юзать хрен знает какой шифрованный код, есть 100500 открытых цмс на php.

Не лезь с 4.2 куда не надо.

По теме: смотри вывод phpinfo, там должна появится информация о лоадерах если ты их правильно установил, с вероятностью 99% ты что то не правильно прописал в php.ini, или не в тот :)

5.3 Оптимайзером не поддерживается, тут дело в другом.

tazhate ★★★★★ ()
Ответ на: комментарий от wingear

И еще копирайт зенда внизу страницы. Правда,всё это связано с самим фреймворком, который поставил apt-get'ом. Странно, что zendOptimizer'а нет для php>5.2, только ZendGuardLoader дальше. Попробую откатить php до 5.2 и поставить.

Ты вапще не то поставил. ZendGuard не связан с лоадером, я тебе написал как делать.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Не лезь с 4.2 куда не надо.

4.2? Где?

Чисто для оптимизации сущесвуют более производительные аналоги вроде xcache.
Соответственно использоваться лоадеры (и оптимайзеры) могут только для закрытого кода. :)

5.3 Оптимайзером не поддерживается, тут дело в другом.

Да какая разница как оно называется? :)
Хоть Zend Optimiser, хоть Zend Guard Loader.

Факт в том, что он не правильно прописал подгрузку в .ini, вот и все. :)

winddos ★★★ ()
Ответ на: комментарий от winddos

Факт в том, что он не правильно прописал подгрузку в .ini, вот и все. :)

Ты читал, что я написал? Факт в том, что он установил другой продукт, а тот, который ему нужен НЕ поддерживает 5.3 пхп.

Чисто для оптимизации сущесвуют более производительные аналоги вроде xcache.

Оптимайзер не для оптимизации используют, а для дешифровки кода, который им криптанут.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Ты читал, что я написал? Факт в том, что он установил другой продукт, а тот, который ему нужен НЕ поддерживает 5.3 пхп.

Разве новые лоадеры не грузят старые закодированные файлы (php > 5.0)?

Оптимайзер не для оптимизации используют, а для дешифровки кода, который им криптанут.

Ну по принципу действия он мало чем отличается от xcache и eaccelerator.
Я много извращенцев встречал, кто то может для этих целей использовать, мало ли :)

winddos ★★★ ()
Ответ на: комментарий от winddos

Разве новые лоадеры не грузят старые закодированные файлы (php > 5.0)?

Причем тут это? Лоадеры идут модулями к конкретной версии пыха, у него в системе пых - 5.3. Оптимайзер есть только для 5.2 пыха и ниже.

Ну по принципу действия он мало чем отличается от xcache и eaccelerator.

Пхп бесполезно оптимизировать, все равно лагать будет ^_^

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Причем тут это? Лоадеры идут модулями к конкретной версии пыха, у него в системе пых - 5.3. Оптимайзер есть только для 5.2 пыха и ниже.

Ты видимо очень выборочно куски постов читаешь :)

Цитирую первый пост:

Скачал отсюда сначала Zend Guard Loader для php 5.3, но после прописывания путей к .so в php.ini и перезапуска апача ничего не изменилось.

Но если честно я понятия не имею декриптует ли «лоадер» старые файлы изначально предназначенные для оптимайзера.
Знаю только, что между php 4 и 5 там была большая разница, а дальше не следил.

Пхп бесполезно оптимизировать, все равно лагать будет ^_^

Прирост производительности они таки дают достаточно большой, 30%+ на тяжелом проекте.
Хотя это лишь доказывает убогость архитектуры php подефолту :)

winddos ★★★ ()
Ответ на: комментарий от winddos

Но если честно я понятия не имею декриптует ли «лоадер» старые файлы изначально предназначенные для оптимайзера.

Нет. Еще раз: это разные продукты.

Но если честно я понятия не имею декриптует ли «лоадер» старые файлы изначально предназначенные для оптимайзера.

Да.

Хотя это лишь доказывает убогость архитектуры php подефолту :)

Именно :)

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Не пойму, какой каталог нужно указывать, чтобы php с поддержкой апача собрать(решил на хосте делать, там гента, но в ебилдах 5.2 уже нет). Скачал какой-то, но он валится при попытке сделать дайджест. При этом, если собирать из исходников, почему-то в упор не видит каталога апача:

haineko php-5.2.12 # ./configure --with-apache=/usr/include/apache2/
...
configure: error: Invalid Apache directory - unable to find httpd.h under /usr/include/apache2/
haineko php-5.2.12 # ls /usr/include/apache2/httpd*
/usr/include/apache2/httpd.h

В коде рабочих ебилдов тоже не нашел, что в параметр with_apache должно передаваться. Или его теперь тоже даунгрейдить?

wingear ★★★★ ()
Ответ на: комментарий от wingear

Даунгрейд уж тем более из реп можно сделать.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

там сначала установщик Guard ругался, что система неподдерживаемая(потому и поставил в виртуалке ubuntu) - а он, оказывается, не нужен. Правда, на том сервере, где всё в итоге будет, стоит Debian(в Hyper-V). Поставил php-5.2.17 в локальный оверлей, но спотыкается на том, что может найти патчсет php-patchset-5.2.17-r0.tar.bz2. Жаль, что здесь файл уже удален. Будем искать.

wingear ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.