LINUX.ORG.RU
решено ФорумAdmin

nginx 1.1.19 и неправильное определние ИП клиентов

 , ,


0

1

Вообщем ситуация такая, обновился через репозиторий до Ubuntu 12.04. На сервере установлено nginx + apache2 + php. До обновления все работало как часы, после обновления nginx удивительно начал тупить. Крутил конфиги не помогло. Выдает у всех клиентов ип 127.0.0.1 хотя mod-rpaf работает и настроен корректно.

nginx version: nginx/1.1.19 TLS SNI support enabled configure arguments: --prefix=/etc/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-log-path=/var/log/nginx/access.log --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --lock-path=/var/lock/nginx.lock --pid-path=/var/run/nginx.pid --with-debug --with-http_addition_module --with-http_dav_module --with-http_geoip_module --with-http_gzip_static_module --with-http_image_filter_module --with-http_realip_module --with-http_stub_status_module --with-http_ssl_module --with-http_sub_module --with-http_xslt_module --with-ipv6 --with-sha1=/usr/include/openssl --with-md5=/usr/include/openssl --with-mail --with-mail_ssl_module --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-auth-pam --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-echo --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-upstream-fair --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-dav-ext-module

Конфиги:

nginx.conf

user www-data; worker_processes 1;

error_log /var/log/nginx/error.log; pid /var/run/nginx.pid;

events { worker_connections 1024; }

http { include /etc/nginx/mime.types; default_type application/octet-stream; server_names_hash_bucket_size 64; access_log /var/log/nginx/access.log;

sendfile on; #tcp_nopush on;

#keepalive_timeout 0; keepalive_timeout 65; tcp_nodelay on;

gzip on; gzip_proxied any; gzip_min_length 1100; gzip_http_version 1.0; gzip_buffers 4 8k; gzip_comp_level 9; gzip_types text/plain text/css application/x-javascript text/xml application/xml application/xml+rss text/javascript;

include /etc/nginx/conf.d/*.conf; include /etc/nginx/sites-enabled/*; }

host

server { listen 80; server_name forum.redcode.pro; access_log /var/log/nginx.access_log;

location ~* .(jpg|jpeg|gif|png|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|tar|wav|bmp|rtf|swf|ico|flv|txt|xml|docx|xlsx)$ { root /var/www/forum.redcode.pro; index index.html index.php; access_log off; expires 30d; }

location ~ /.ht { deny all; }

location / { proxy_pass http://127.0.0.1:8002; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for; proxy_set_header Host $host:80; proxy_connect_timeout 60; proxy_send_timeout 90; proxy_read_timeout 90; proxy_redirect off; proxy_set_header Connection close; proxy_pass_header Content-Type; proxy_pass_header Content-Disposition; proxy_pass_header Content-Length; }

}


хотя mod-rpaf работает и настроен корректно

Учитывая, что конфиг файла apache нет, я позволю себе усомнится в этом.

zgen ★★★★★ ()
Ответ на: комментарий от zgen

config rpaf

<IfModule mod_rpaf.c> RPAFenable On RPAFsethostname On RPAFproxy_ips 127.0.0.1 192.31.0.101 </IfModule>

host apache cofig

<VirtualHost *:8002> ServerAdmin sience74@google.com ServerName forum.redcode.pro DocumentRoot /var/www/forum.redcode.pro

<Directory /> Options FollowSymLinks AllowOverride All </Directory>

<Directory /var/www/forum.redcode.pro> Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory «/usr/lib/cgi-bin»> AllowOverride All Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory>

ErrorLog /var/log/apache2/forum.redcode.pro-error.log

# Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn

CustomLog /var/log/apache2/forum.redcode.pro-access.log combined

</VirtualHost>

domet ()

Выложи конфиги на pastebin, невозможно читать же.

tazhate ★★★★★ ()
Ответ на: комментарий от domet

Визуально все верно, скорее всего реально nginx кривит. Попробуй из реп предыдущей убунты поставить его (только nginx) и проверь.

зы: рестартил после ковырялок апач и нгикс? %)

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Да конечно. Сейчас попробуем поставить старенький nginx. Это возможно сам деб пакет репозитория кривой?

domet ()
Ответ на: комментарий от domet

Это возможно сам деб пакет репозитория кривой?

Врядли.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Поставил 1.0.5 из прерыдущего репа, ситуация осталась. Ковыряюсь уже 3ий день. Уже грешу на саму ОС, думаю скорей обновилась криво!

domet ()
Ответ на: комментарий от domet

Уже грешу на саму ОС

Это просто пускалка приложений. Проблема может быть только в трех вещах: похапэ, апач, нгикс. Nginx мы вернули, следовательно косяк не в нем.
ну да, и php info тебе в помощь, создай его и проверь как там детектится remote addr.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Спасибо проблема решена, просто надо было откатить rpaf мод.. вся проблема только в нем. на новом nginx и 22ом апаче со старым rpaf все арбайтен! )

domet ()
Ответ на: комментарий от domet

И да, ОЧЕНЬ советую перейти на fastcgi и выкинуть апач совсем.

tazhate ★★★★★ ()
Ответ на: комментарий от domet

не забудь в мейл рассылке нгинкса сказать о своей ошибке.

ventilator ★★★ ()
Ответ на: комментарий от ventilator

Тема не решена на самом деле

Забыли просто конфиг поправить у mod_rpaf /etc/apache2/mods-available/rpaf.conf Было: <IfModule mod_rpaf.c> Надо: <IfModule mod_rpaf-2.0.c>

И усе :)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.