LINUX.ORG.RU
решено ФорумAdmin

Lenny to Sqeeze


0

2

Пытаюсь обновить Lenny до Sqeeze. Изменил в /etc/apt/sources.list все вхождения lenny на sqeeze и stable на testing. После aptitude update делаю aptitude install apt dpkg aptitude. Оно ругается на python 2.6 и пытается снести полсистемы. Что же делать?

Ответ на: комментарий от AITap

К сожалению, то же самое:

Следующие пакеты имеют неудовлетворённые зависимости:
python-apt: Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.
libapt-pkg-perl: Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.
apt-utils: Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.
apt: Конфликтует: python-apt (< 0.7.93.2~) но установлен 0.7.7.1+nmu1 и удерживается.
libept0: Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.
synaptic: Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.

Предлагает снести gnome и ещё много чего.

generator ★★★ ()
Ответ на: комментарий от generator

> но установлен 0.7.7.1+nmu1 и удерживается.
Вы это сами делали?

Зависит: libapt-pkg-libc6.7-6-4.6 который является виртуальным пакетом.

И действительно, этот пакет предоставляется apt (кстати, уже 6.9, а не 6.7).
Может быть, попробовать его поставить командой вида aptitude install libapt-pkg-libc6.9-6-4.6 apt?

AITap ★★★★★ ()
Ответ на: комментарий от generator

Варианты:

1) grep -Ri python-apt /etc/ /var/lib/dpkg/

2) LANG=POSIX apt-get dist-upgrade

то же сообщение будет выведено на английском. дальше в гугл

3) (временно и черезж) попробовать через aptitude.

aptitude - F10 -> отменить все незаконченные действия

потом выбрать обновление и посмотреть список предложенных вариантов

router ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.