LINUX.ORG.RU
решено ФорумAdmin

Отличие: /etc/init.d/lighttpd start и вручную


0

0

Воопщем бяка с php-cgi.

/etc/init.d/lighttpd start

domain.com/index.php -> 500 - Internal Server Error

error.log

2010-05-14 10:47:02: (log.c.97) server started

2010-05-14 10:47:06: (mod_fastcgi.c.1768) connect failed: Permission denied on tcp:127.0.0.1:6100

2010-05-14 10:47:06: (mod_fastcgi.c.2956) backend died; we'll disable it for 5 seconds and send the request to another backend instead: reconnects: 0 load: 1

2010-05-14 10:47:12: (mod_fastcgi.c.2769) fcgi-server re-enabled: tcp:127.0.0.1:6100

если lighttpd -f /etc/lighttpd/lighttpd.conf с -D или без - все работает.


}:-E ]

Конченный audit.

type=AVC msg=audit(1273861733.563:20611): avc: denied { name_connect } for pid=19365 comm=«lighttpd» dest=40100 scontext=root:system_r:httpd_t:s0 tcontext=system_u:object_r:port_t:s0 tclass=tcp_socket

Хм..и чего с аудитом делать?

KosmiK ()
Ответ на: }:-E ] от KosmiK

Solved

Вот срань хитрая >_<

semanage port -a -t http_port_t -p tcp 40100

и пашет ведь.

KosmiK ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.