LINUX.ORG.RU
ФорумAdmin

Проблема с установкой PHP 5.2.6


0

0

При выполнении конфигурации выдает следуещее:

checking for MySQL support... yes

checking for specified location of the MySQL UNIX socket... no

checking for MySQL UNIX socket location... /tmp/mysql.sock

configure: error: Cannot find MySQL header files under yes.

Note that the MySQL client library is not bundled anymore!

Параметры конфиругации:

./configure --prefix=/usr/local/php5 --with-apxs2=/usr/local/apache/bin/apxs --with-mysql

MySQL собирался из исходников, параметры конфигурации:

./configure --prefix=/usr/local/mysql

Ответ на: Re: Проблема с установкой PHP 5.2.6 от true_admin

Re: Проблема с установкой PHP 5.2.6

checking for MySQL support... yes
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... no
checking for mysql_close in -lmysqlclient... yes
checking for MySQLi support... yes
checking whether to enable embedded MySQLi support... no
mysql_config not found
configure: error: Please reinstall the mysql distribution

San4oP ()
Ответ на: Re: Проблема с установкой PHP 5.2.6 от true_admin

Re: Проблема с установкой PHP 5.2.6

> теперь помоги ей найти путь к mysql_config.

как я понял, это надо сделать так "--with-mysqli=/etc/my.cnf" ?

результат:
checking for MySQL support... yes
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... no
checking for mysql_close in -lmysqlclient... (cached) yes
checking for MySQLi support... yes
checking whether to enable embedded MySQLi support... no
mysql_config not found
configure: error: Please reinstall the mysql distribution

San4oP ()
Ответ на: Re: Проблема с установкой PHP 5.2.6 от Deleted

Re: Проблема с установкой PHP 5.2.6

Конечно, до этого нормально собирал, теперь все не так.
Скорее ОС не удачно поставили при установке сервера, т.к. еще другие баги исправлял через их поддержку. Но а вот с такими проблемами они дерут деньги, а так помогать не будут =(


Сейчас у меня проблема только с PHP, не подключается как модуль в Apache и не находит установленный MySQL (хотя явно это указано где все расположено).

San4oP ()

Re: Проблема с установкой PHP 5.2.6

я вообще не понимаю что за идиотские депенденсы. PHP вообще-то не должен в принципе требовать mysql. есть для этого php-extensions. а что за ось?

Komintern ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.