LINUX.ORG.RU
ФорумAdmin

при установке Ati Official Drivers ошибка?


0

0

Всем привет!

Возникла проблема, которой на других машинах (аналогичных) вроде бы не возникала..... ati mobility x1300

Slackware 11, kernel 2.6.19

- делаю tmpfs на /dev/shm , монтирую ...ок - ядро пересобрано без Character Devices > DRM как обычно ...ок - в xorg.conf добавляю Section DRI ...ок

выхожу из Х-ов, перехожу в каталог с драйвером.... sh ./ati-driver-installer......run в самом конце установки пишет, что возникла ошибка... и указание посмотреть лог в /usr/share/ati/fglrx-install.log

//-------------------------------------------------------------------- [Message] Kernel Module : Trying to install a precompiled kernel module. [Message] Kernel Module : Precompiled kernel module version mismatched. [Message] Kernel Module : Found kernel module build environment, generating kernel module now. ATI module generator V 2.0 ========================== initializing... cleaning... patching 'highmem.h'... assuming new VMA API since we do have kernel 2.6.x... Assuming default VMAP API Assuming default munmap API doing Makefile based build for kernel 2.6.x and higher make -C /lib/modules/2.6.19.my/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules make[1]: Entering directory `/usr/src/linux-2.6.18' CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o In file included from /lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:41, from /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:357: /lib/modules/fglrx/build_mod/2.6.x/drmP.h:126:1: warning: "DRM_DEBUG_CODE" redefined /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:177:1: warning: this is the location of the previous definition /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:475: warning: initialization from incompatible pointer type /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `firegl_stub_open': /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:598: warning: assignment discards qualifiers from pointer target type /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_request_irq': /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2676: warning: passing arg 2 of `request_irq' from incompatible pointer type /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_smp_call_function': /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4116: warning: passing arg 1 of `smp_call_function' from incompatible pointer type /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `KAS_ExecuteAtLevel': /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4789: warning: 'flags' might be used uninitialized in this function /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `KAS_SlabCache_Destroy': /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5008: error: void value not ignored as it ought to be make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Ошибка 1 make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Ошибка 2 make[1]: Leaving directory `/usr/src/linux-2.6.18' make: *** [kmod_build] Ошибка 2 build failed with return value 2 [Error] Kernel Module : Failed to compile kernel module - please consult readme. //------------------------------------------------------------------ После установки конфигурирую ./aticonfig --initial перезагружаюсь, разрешение и все такое нормально.... но direct rendering не работает.... и fglrxinfo выает что используются Mesa.... sad.gif

В каком направлении копать? smile.gif Спасибо!

Re: при установке Ati Official Drivers ошибка?

По ходу то, за что смог зацепиться глаз: с дровами ATI сейчас идет модуль кернел, так что исходники ядра не обязательно должны быть установлены (хотя и не помешает в принципе), а вот заголовки (headers) по-моему должны быть - вот он тебе, возможно, и ругается, что не может скомпилить модуль кернел. Ты пишешь, что у тебя ядро 2.6.19, а программа установки пишет фразу "Entering directory `/usr/src/linux-2.6.18" - может, у тебя версия дров нехорошая? ATI только недавно выпустила дрова под ядро 2.6.20 - до этого поддержка была только для ядра 2.6.18. Советую внимательно проверить данную тему =) Ну и в конфиге xorg должен быть драйвер fglrx в секции Device, а не что-либо другое.

slaver ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.