LINUX.ORG.RU

проблема с fglrx


0

0

поставил обратно свой radeon9500 вместо geforcefx 5700

скачал драйвер fglrx, сделал rpm2tgz и installpkg

при компиляции модуля вываливается с ошибкой

# pwd
/lib/modules/fglrx/build_mod
# ./make.sh
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.12-rc3-mm2/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.12-rc3-mm2'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/agp3.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/nvidia-agp.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `agp_find_supported_device':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7134: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7154: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7159: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7185: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7205: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7225: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7230: error: structure has no member named `slot_name'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:6526: warning: unused variable `cap_ptr'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `__fgl_agp_init':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7611: warning: `pm_register' is deprecated (declared at include/linux/pm.h:107)
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `__fgl_agp_cleanup':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:7621: warning: `pm_unregister_all' is deprecated (declared at include/linux/pm.h:117)
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:6507: warning: 'agp_check_supported_device' defined but not used
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o] Ошибка 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Ошибка 2
make[1]: Leaving directory `/usr/src/linux-2.6.12-rc3-mm2'
make: *** [kmod_build] Ошибка 2
build failed with return value 2

ядро как видно 2.6.12-rc3-mm2, gcc 3.4.3

кто то на лоре говорил, что атишные драйвера не собираются под патчсетами -mm

собрал 2.6.11.8 и ничего не изменилось :(
★★★★★

Re: проблема с fglrx

Тут я уже недавно выкладывал патч для fglrx. Наложи патч на драйвер, потом компиль.

snigga ★★★ ()
Ответ на: Re: проблема с fglrx от snigga

Re: проблема с fglrx

нашел патч тут: http://www.linux.org.ru/jump-message.jsp?msgid=844593

# pwd
lib/modules/fglrx/build_mod/2.6.x
# patch -p0 -i ati.patch
(Stripping trailing CRs from patch.)
patching file firegl_public.c
Hunk #1 succeeded at 216 (offset -1 lines).
Hunk #3 succeeded at 2706 (offset -1 lines).
Hunk #5 succeeded at 2803 (offset -1 lines).
patch unexpectedly ends in middle of line
Hunk #7 succeeded at 2902 with fuzz 1 (offset -1 lines).

и все равно такая же ошибка :(

JB ★★★★★ ()

Re: проблема с fglrx

Посмотри ебилд у жентульменов - у них все патчи есть.

Для последней версии 8.12.10 это: http://gentoo.kems.net/gentoo-x86-portage/media-video/ati-drivers/ati-drivers...

Соответственно, наложи 2 (если amd64, то 3) патча:

1) http://gentoo.kems.net/gentoo-x86-portage/media-video/ati-drivers/files/fglrx...

2) http://gentoo.kems.net/gentoo-x86-portage/media-video/ati-drivers/files/8.8.2...

Deleted ()
Ответ на: Re: проблема с fglrx от Deleted

Re: проблема с fglrx

чтобы наложить первый патч пришлось вручную указать какой файл патчить

и все равно такая же ошибка :(

может все дело в gcc? никто не пробовал собирать fglrx при помощи 3.4.3?

JB ★★★★★ ()
Ответ на: Re: проблема с fglrx от JB

Re: проблема с fglrx

>никто не пробовал собирать fglrx при помощи 3.4.3?

Последние несколько релизов собираю именно им. Но так как ядро у тебя какое-то супер новое, да еще и с патчами, то всё может быть. Последние дрова даже на 2.6.11 без патчей не собираются. Короче тебе на форум rage3d.com, в раздел Linux, там тема есть про патчи.

RatMann ★★ ()
Ответ на: Re: проблема с fglrx от Deleted

Re: проблема с fglrx

> Слакварь? зачем гцц из тестинга взял? :)

а что с ним не так? :( все остальное вроде собирается

JB ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.