LINUX.ORG.RU

Slackware 11 & ATI


0

0

Уважаемые! Никак не могу накатить ati-8.28.8 на вновь установленное ядро 2.6.18 (test26 из слаковского дистра). Видюха radeon 9200.

Выдает вот такую мессагу:

[Message] Kernel Module : Trying to install a precompiled kernel module. [Message] Kernel Module : Precompiled kernel module version mismatched. [Message] Kernel Module : Found kernel module build environment, generating kernel module now. ATI module generator V 2.0 ========================== initializing... Error: kernel includes at /lib/modules/2.6.18/build/include do not match current kernel. they are versioned as "" instead of "2.6.18". you might need to adjust your symlinks: - /usr/include - /usr/src/linux [Error] Kernel Module : Failed to compile kernel module - please consult readme.

И что мне делать дальше?


Re: Slackware 11 & ATI

Вроде бы суть претензий описана предельно ясно. Симлинк /usr/src/linux должен указывать на каталог с сырцом 2.6.18

Lumi ★★★★★ ()

Re: Slackware 11 & ATI

Выкинуть проприетарное поделие и юзать свободный драйвер r200. Всё равно поддержку твоей видюхи из новых версий atiшных дров выкинули.

dn2010 ★★★★★ ()
Ответ на: Re: Slackware 11 & ATI от dn2010

Re: Slackware 11 & ATI

+100, собрал иксы 7.1 с DRI из Mesa-6.5.1 + самые новые драйвера из дерева Х11 - в сравнении с чистым xorg-7.1 3D работает в если не в разы, то на десятки процентов быстрее.

Осталось прикрутить пиксельные шейдеры и нормальное раскидывание по текстурным процессорам - и враз наступит щастье.

e ()
Ответ на: Re: Slackware 11 & ATI от dn2010

Re: Slackware 11 & ATI

можно ли поконкретней про этот драйвер и где его можно найти ?

anonymous ()
Ответ на: Re: Slackware 11 & ATI от anonymous

Re: Slackware 11 & ATI

А его искать не надо, надо только x11 переставить, чтобы потереть то, что тебе installer ATiшный наковырял в системе. После чего X -configure или лучше xorgsetup :) и дальше в полном соотетствии с заветами FAQ: http://www.linux.org.ru/books/lor-faq/lorFAQ-3.html#ss3.8

dn2010 ★★★★★ ()

Re: Slackware 11 & ATI

Для ядра 2.6.18 надо поставить пакет с модулями из /testing.

fdn721 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.