LINUX.ORG.RU
ФорумAdmin

Ошибка docuwiki

 , ,


0

1

Добрый день.

Есть Ubuntu 16.04.5 LTS и свежеустановленная docuwiki.

Пытаюсь на ней настроить доменную авторизацию следующим образом:

$conf['title'] = 'BUH';
$conf['lang'] = 'ru';
$conf['tagline'] = 'Добро пожаловать';
$conf['license'] = 'publicdomain';
$conf['toptoclevel'] = '2';
$conf['maxtoclevel'] = '5';
$conf['useacl'] = 1;
$conf['authtype'] = 'authad';
$conf['superuser'] = '@admin';
$conf['disableactions'] = 'register';
$conf['plugin']['authad']['account_suffix'] = '@domain.ru';
$conf['plugin']['authad']['base_dn'] = 'DC=domain,DC=ru';
$conf['plugin']['authad']['domain_controllers'] = 'dc.domain.ru';
$conf['plugin']['authad']['debug'] = 1;

Но получаю ошибку: DokuWiki Setup ErrorSomething unforseen has happened: Maximum action transitions reached.

Причем это происходит только тогда, когда прописываю параметр $conf['authtype'] = 'authad'; Без него все работает, кроме доменных учеток. С ним - не работает ничего, а только ошибка, которая приведена выше.

Подскажите, в чем может быть проблема? Поддержка LDAP в php включена, это проверила.

Спасибо.

Ответ на: комментарий от zgen

Спасибо за отклик.

Да, я это тоже нашла, но, насколько понимаю, authad должен быть включен по умолчанию.

По крайней мере, я не могу найти, где раскомментировать строку с ним или где он должен быть включен?

Не подскажете, в какой стороне это поискать?

Еще раз спасибо.

Nychary ()
Ответ на: комментарий от Nychary

Подскажу что вам рано или поздно придется привыкать читать документацию. Т.к. часто вся помощь заключается в том, что кто-то за вас делает запрос в гугл. Иначе бы всем нужно было всегда ставить ПО, всю инфраструктуру, читать документацию, проверять плагины и потом давать вам совет. Это неэффективно.

https://www.dokuwiki.org/plugin_installation_instructions
https://www.dokuwiki.org/plugin:extension#enabling_disabling_plugins

zgen ★★★★★ ()